Working on a HUGE model


#1

Hello all

So I’m working on an admittedly HUGE model and i’m having speed and crashing issues. Unfortunately there’s no way around the amount of detail required and so I’m stuck with that. I know most of it is probably due to the size but I was wondering if I’ve got any problems that I don’t know about that could be holding me up.

Thank you !!


#2

Download that at your own risk. It crashed my main computer and I’m having problems recovering it. All I’m getting at startup is a giant cursor. Never again.


#3

Wow - it hasn’t done anything like that to me, or the other person who has been working on it remotely for me.

I was just talking about it being laggy and a couple of bug splats a day.

Apologies.


#4

The largest model I work with is 1.7GB (250 ha of LiDAR data), it very laggy, it just normal once the model gets that big.


#5

What happened to Box’s computer sounds scary but nothing bad happened when I opened it, except running extremely slowly.

There’s a lot of geometry in there with 17.3M Edges, nearly 8M Faces, 22k component instances, 8k groups. Things start to slow down for me over 1M edges and you’re way above that. There are bound to be ways to speed up working on this model, but its hard for me to even look at it as it is so slow on my computer. There are some objects quite far from the main buildings about 260m away on the negative x-axis (red) which makes orbiting behave a bit weird.

Try and replace some of your thousands of components with textures. Do you really need to model thousands of books individually?

If you really can’t get rid of any geometry there’s techniques for making it more manageable. Hide the rest of the model and other instances when editing groups and components. Just turning the books layer off helps to speed it up as does working in monochrome mode so no textures and transparencies.

You could work on big chunks as components in separate files and bring them in to the main model when they’re finished.

There’s also some weird hidden geometry 1.4km from the origin in positive xy direction that looks buggy. The coords don’t correspond with the dimension tool. If you copy it over to a new file it’s a weird broken line that looks hidden but won’t show with the option-eraser tool.


#6

@Gemma_Baird, why don’t you share this relevant information about file size etc. in advance with your request to have a look at such a huge file?


#7

Several earlier suggestions might make the model more manageable, particularly replacing over-detailed geometry with textures, and working in monochrome mode. And if you have used components imported from the 3D Warehouse, they are often grossly over-detailed.

One other thing that will help is to use layers to turn off all components or groups that aren’t needed while you are modelling.

Working with Scott Baker (@NewThinking2) on a model about half your file size, we found that using layers to suppress the display of objects not needed while drawing helped very considerably.

Simplifying components also helped reduce the edge and face count dramatically. See for example this thread

Even on a very fast machine, a Sketchup file of this size will be slow to load, orbit, and edit, but it can be speeded up using any or all of these techniques.

See also https://help.sketchup.com/fr/article/3000142


#8

hello,

It runs pretty smoothly on my computer but it freezes from time to time especially - of course - when it autosaves.
I changed the style from shaded with texture to shaded and it runs smoothlier.

The problems are the books, you just have too many of them !

I would use fredo6’s ghostcomp if I were you https://sketchucation.com/forums/viewtopic.php?f=323&t=21469

Or even simplier, replace those 3D books by a simple texture that will ligthen your file a lot !

you may also check your components axes as there is some clipping with your model

EDIT : It seems you are using VRAY, as I see vray spotlights. Forget about ghostcomp, make proxies out of your books / shelves. check out tutorials if you don’t know how to !


#9

I think the clipping was caused by some hidden geometry 3.5km from the origin. Deleting that fixed the clipping and orbiting issues.

My processor speed of 2.26Ghz in one thread was making it slow for me.


#10

You’re not “stuck” with over-modeled books built with 12-segment arc spines or overstuffed furniture and pillows, overstuffed with massive amounts of unnecessary geometry.

Nor are you required to render the model onscreen using the abysmal Architectural Design Style.
It may look nice, but rendering Profiles absolutely kills performance.
Components and stray edges left scattered about in the model space don’t help either.

See this compendium of performance modeling techniques at the SketchUp Sage:


File size is not a measure of model performance.
Modeling technique has a tremendous impact upon performance.


This, found in the model.
It’s the stuff a bloated, laggy model is made of…


#11

McGordon

There’s a lot of geometry in there with 17.3M Edges, nearly 8M Faces, 22k component instances, 8k groups.

Unfortunately I know - its a beast !

Try and replace some of your thousands of components with textures. Do you really need to model thousands of books individually?

and again, unfortunately as the proposed use for this model is a perspective section at a very large scale the only way to get the shadows and geometry to work correctly is to put the books in - they are only going in where the cuts are going to be though so I am keeping them to a minimum.

There’s also some weird hidden geometry 1.4km from the origin in positive xy direction that looks buggy. The coords don’t correspond with the dimension tool. If you copy it over to a new file it’s a weird broken line that looks hidden but won’t show with the option-eraser tool.

Hadn’t noticed that ! - thank you, its gone now.


#12

Working with a - now - 650MB file, I find I simply cannot have autosave turned on. Actually, this was true when it was only half the size. The saving/retrieving now takes almost 2 minutes, even on my top-of-the-line iMac with 3TB on a Fusion drive. If that happens in a the middle of another operation, it basically freezes the machine, often crashing it. I simply have to get to a certain point where the distress of losing date would be unbearable, and then do a save while I check my email etc.
I have 32GB RAM and a 4Ghtz i7 processor too. And 4GB on my AMD Radeon R9 M395X too.
Even so, I turn off most layers when I am doing major mods.


#13

I have also had same story, I recently invested in a money no object new PC, and I mean serious, 5.1 GHz i7 hex core! 32GB Corsair gaming, SSDs, the ultimate CAD card and 4k Asus monitor, probably 3 times as quick as a decent PC but to use SketchUp I needed 100 times the speed and my model was growing quicker than technology! This is what I found:

  1. For me, SketchUp 2018 is slower than 2017
  2. SketchUp does not slowly degrade as your model increases in complexity, it suddenly drops off a cliff and goes from great tool to unusable all of a sudden!
  3. When you think it has hung and you have potentially hours of unsaved work leave it alone for 20 mins or more, it will come back! (I once deleted the wrong bit, clicked Undo, it tool over an hour to Undo!)
  4. Divide you model into artificial layers, I have a layer called trees & shrubs (contains about 200 highly detailed 3D trees!), you could have one called books. Turn off the complicated layer that contains the 2 or 3 million edges and you will find your drawing comes alive again and you can edit it once more. When you want to do the 3D presentations, turn the layers back on. Sadly hiding groups does not speed up SketchUp, it still processes them, it’s a stupid bug we have to live with.

Its a shame that many of the responses say ‘make your drawing simple’, OK your drawing has some wacky stuff in it but that’s not the point, SketchUp should be encouraging us to go more detailed by continually making their software faster and more efficient, but then what do expect for free!


#14

In fact they have done so with every release. The slowdown you describe happened with about 100 000 faces in v. 3.0, today even a more that 10 times larger model can still be workable. However, there still remain good reasons not to waste precious polygons for mere eye candy.


#15

Eye Candy is good, I designed some double glazed windows with the hinges, catches, and rubber seals using the actual aluminium profile, it even has all the screws and they have recessed PZ2 heads! What you cannot do (yet) is to go into something like ambient controls and open all the windows in your model to 10 or 20 degrees! SketchUp 2028 perhaps!
‘Mere Eye Candy’ has a time and place, I do agree that it’s origins are usually associated with being bored with your laptop on a long haul flight, run out of emails and seeing if you can use SketchUp to model an exact bolt, nut or screw that a
year later your drawing will have a few thousand of them in!


#16

Hi! I haven’t used but I think that you can use references with Trimble Connect. Maybe is a way to divide the size of the file.


#17

Hi @Gemma_Baird, I created a model which is pretty large & all the detail made it pretty unworkable. I followed some of the suggestions outlined above, and it really helped. It would be worth your time to understand them.

As an example, you mentioned that the only way to get the shadows & geometry to work correctly is to put the books in. What I found, is that the only way to get my model to look right, was to remove the detail! I had pretty detailed facades on my buildings, but when I backed away to see a whole city block, the detail was lost as the lines converged to be a black mass. I moved the different buildings to different files / models, where all the detail was retained. Then I exported .jpg images of the facades to use as textures on my buildings in the city view. That not only improved the speed of things, but also the appearance.

Also, turning off textures while I was modeling and turning off layers that were not where I was working - these were REALLY helpful for improving the speed of SU rendering and movement, and they were really easy to do!


#18

I use sketchup now and then, but what i learned doing is making layers for categories. So layers can be named foliages, scenery. extras, buildings, main building, non-used, temp-off.

This really helps when you working on the main structure. You can turn off all non-related items and this makes moving and adjsuting the scene much faster. Also what helps me is the kind of style i use while editting. Also shadows should only be turned on when needed.

Its a pitty SU cant properly link models into a scene. Have them linked as low proxy model would be great addon


#19

Everything you download from the warehouse should be quarantined, and examined.
I bring it into a new model, and check for layers and materials. Everything in that component, (with rare exceptions, should be on Layer ).
There is no reason to have, for example, a car’s tire, wheels, dashboard, glass, seats, and body panels on different layers. if you need one of those cars, because it is going to appear very close to the camera in a specific scene, clean it up. Get everything on layer zero, look for over-abundant textures…try to make all body panels the same material ., renamed as “VEHICLE-PAINT-001” for instance.
Then later, you can edit the color globally. Better yet, make anything that needs to be color panels, default material, and everything else black, glass, whatever. Then you just “paint” each instance of the car with different material/colors. Sometimes there are so many embedded materials within materials that-it’s amazing SketchUp DOESN’T crash! Or overly detailed tires or wheels. Simplify all that stuff if you are going to use it repetitively, and then save it, cleaned up, in a special archives wherever you save stuff.

And if you know that cars, or trees, or books for example, are not going to be seen very closely in the majority of your views, then for gods sake don’t use highly detailed components in those areas. You’ll slow down your model for no added benefit. There are plenty of low-poly components for trees and cars that will do just fine when seen from a distance. Also, as other guys have said, bookshelves…use a component that has an image of books of the front face…maybe 48 inches long or so… there are some good ones on the warehouse. Sometimes I will take on e of those, and, in 3D, vary the height of the different books so it looks more realistic…but still, it’s mainly all one rectilinear solid…just the jpeg image on the front makes it appear as if it’s a stack of many books…and even close up, this will suffice.


#20

As things are now, I agree with this - mostly.

There are two issues I run into all the time with 3dWarehouse models: complexity and scale. Of these two, if I open the detail page for the model (instead of downloading it from a search result, collection, or browsed list), I can see enough statistics that I can make a reasonable guess as to whether or not the model is likely too simple or too complex for my application.

There’s a third issue that occasionally comes up: Use of layers. I generally don’t want to bring an unknown set of layers directly into my model.

If the following two statistics were added to the detail page for each model, I’d be far more able to tell if it’s “safe” to bring the warehouse model directly into my model:

  • Longest dimension - show both imperial and metric versions!
  • number of layers (excluding layer0)

The first lets me know if the model is close enough in size to the scale I need to bring it directly into my model. The second - if non-zero - tells me to quarantine and examine the layer structure before using.

But if the polygon count, longest direction, and number of layers (=0) are all aligned to my purpose, I’d have no qualms about bringing it directly into my model.