Wireframe in KMZ imports

Preparing the model

  • from 2.000.000 tris to 20.000 tris

  • preparing the place for inserting the new 3D model

exported as DAE or OBJ

  • without missing surfaces and a lighter model (20K) to work with in SketchUp

It was too heavy too import into SU with Tig’s OBJ Importer.

Unity Pro Boulderize didn’t work.

Blender Un-Subdivide. No luck.

Decimate. Nope.

Apply JPG. Out of luck.

Key frames playing forever. Done!

I’d need to memorize a lot of these key press sequences to get modifiers to work. It’s not intuitive or obvious to me at all how to get Blender to do anything. But I did make that rock the other day… maybe I’ll finish the texture some day :^)

Not necessarily, you can only use the buttons in the interface (three clicks), or, if you want, you can set a shortcut for Modifiers and then just press the one you need.

For your case, set Viewport shading > Material Preview (or Render Display)

1 Like

Okay. I was setting Decimate Factor .01, .001, .0001, .00001… but not Ratio to .1 So now that works. For whatever reason, plus some button clicking, the JPG was applied as a texture… I guess in Object Mode ->Texture Paint.

Sculpt Smooth possible… but freezing every time. Decimate!!!

Still Flatten is some kind of ham-handed sluggish thing.

Now let’s see this monstrosity:

Need a Chisel or Sledge Hammer Tool in Blender to smash that mesh down.

Oh - and thank you, @mihai.s ;^)

1 Like

TC Visualizer:

There’s a glitch with the sun slider…

Apply the modifier first, and then use the Smooth brush in the Sculpt Mode.

I have another mission that is interesting because of the topology and the fact that the building has not been built yet, so I am interested in following through and re-flying the mission as the buildings come out of the ground.

Files are here

The brown in the water is Sargassum, which has made the beach absolutely unusable.

And to illustrate the purpose better, here’s a house that I did a mission on last week.
The owner has already got solar panels. We’re showing him what more panels on the roof and some ground mount would look like and how they would fit.
Angles and dimensions are important. Accurate rendition of the house, windows, water, not so important.

Applied it. Then accidentally unapplied it. Then really applied it. But still no go. It seems it would be like Artisan if I could get it going.

Does the OBJ open with color for you?

After applying the modifier and activating Sculpt Mode, information about the model appears in the status bar at the bottom right… you should no longer have 2,000,000 tris, but much less, by 10 or 100 times.

Both the OBJ file and the DAE file

Yes. That was good (and needed).

In this case when I opened the new OBJ (3D Viewer) from the OP there was no color.

I don’t have an OBJ importer (expired). Tig’s wouldn’t handle either of these.

In Blender, the previous version changed to a pink color. I can’t get the texture / material / jpg to colorize it again. So, I changed it to something useable. Then accidentally changed it to something unusable.

Same with the new one. Can’t get material on it. There is no import jpg. Dragging seems to indicate an import will occur. But nothing shows up in the ‘hierarchy’. Yet, somehow something like that worked last night.

It was awesome to get the triangles reduced and be able to export DAE for import to SU. For me, Blender is totally non-intuitive. The keyframe thing started up out of the blue again… Dunno.

Follow this steps and import DAE

Make sure you have these files in a folder


1 Like

Okay, here’s the problem I created:

Renamed files for human readability:


Missing Viewport Shader:


Viewport Shading - Material Preview previously set. Re-Import, Rotate, (ctrl+a) select Rotation to apply rotation:

Decimate… Smooth…

Smoothing Tool working like a champ now.

Export with setting I already forgot… Import to SU:

Craziness Notes:

*The Blender Manual says in a couple of places to press a key or keys to get radial/pie menu but not which keys.

*One website says to go to File->Preferences->… but my version doesn’t have File->Preferences.

*Edit->Preferences. Exists. Add-ons has about 75 tabs. Finally found Interface: 3D Viewport Pie menus using search, “pie”.

*Seems ctrl+a opens the radial menu.

When you edited the 3D model in Blender, how did you import it to SU?

Before / Progress / After sounds like a good idea.

Ah. I see it. I tried to smooth it out a bit in that go.

You might be able to do what I call ‘Box Fitting’. Push-Pull, Rotate and Align longest/most visible faces of a box to a PC… but to the mesh. If you do that for a building, the angles of all of the panels can be based on that. This might be nice if you’re also thinking of adding sun into the models.

Blender → File → Export → Collada (dae). Select Texture Options → UV, Only Selected Map. Export COLLADA.

SU → File → Import

It’s tempting to create new thread on this.

1 Like

You `ve done it well. Without the ‘Pie’ addon activated, at ctrl+A a window appears instead of the ‘radial pie’, or you can use menu Object > Apply.

If you change the name in File Explorer, you must also change it in the .mtl file


That’s just me going overboard trying to follow what I see being done.

Yes - just going overboard trying to simplify those long names. Hey, but I left the “.3D” on there… ;^)!

I’m satisfied that rendering a KMZ file then inporting into Sketchup is adequate for my needs. I just did a Map Pilot mission over a property, was able to put solar panels on the roofs with accuracy, and then realized I had photographed the cliff face which is close to collapsing. The detail in the model is extraordinary. I output a video.