Windows 7 Installation problem


#1

I’m attempting to install 2015 64-bit SU Make and I get error “Error occurred while attempting to create the directory: C:\ProgramData\Sketchup\Sketchup 2015\Layout”


#2

If you are NOT a member of the Administrators group (on your computer,) you will need to log in to an Administrator account. See instructions (if there is no Administrator account on the login screen):
http://forums.sketchup.com/t/windows-10-installation-problem/14436/4

If you are already in the Administrators group, then once logged in, see:
Installing SketchUp: http://help.sketchup.com/en/article/56085
ie, run the installer by right-clicking and choose “Run as administrator”.


#3

Also, the SketchUp installer needs access to a valid network adapter to complete installation.

There may be a hardware conflict between one of your adapters and something other hardware (some have had a conflict with their Bluetooth adapter.)

See
http://forums.sketchup.com/t/windows-10-installation-problem/14436/9


#4

Hi Dan,

I am a member of the Administrator group and I right clicked and chose “Run
as administrator” and still got the same error message.

John


#5

And make sure there are no hardware conflicts with any of your network adapters. (as explained above)

Have you tried the 32-bit installer ?


#6

Just tried the 32-bit installer and got the same error results.

BTW, I checked for HW conflicts and no problems were flagged.


#7

Do you have UAC (User Account Control) on ?
Control Panel > Action Center > Security

I myself turned it off long ago.

I have Win7 64-bit and have never had any issues installing SketchUp, but I run with UAC off because I use Comodo AV & Internet Security.


#8

If you go to C:\ProgramData, click on nothing, right-click and get Properties, is the folder set to read only? Was a SketchUp folder created, before it failed to make the LayOut folder?


#9

I just turned off the Read Only and got the same results. Also tried
turning off UAC as DanRathbun suggested. That didn’t help either.


#10

Had it got as far as making the SketchUp folder?

I wonder, if you manually make the folders, will it work?

You can see here what folders are made:


#11

Well the only thing I can suggest is, even though your account is an Admin acct., do the following anyway, and try using the system administrator account to install SketchUp:


#12

I also tried installing it with UAC turned off, at your suggestion.same
error results.


#13

Is your antivirus causing this?

Anssi


#14

Can you manually create a “Layout” folder under C:\ProgramData\Sketchup\Sketchup 2015 and see if the installation continues?

Yogesh


#15

Yogesh, that’s what I suggested yesterday, but I don’t know he tried that yet.


#16

Colin, Yogesh,

The Sketchup 2015\Layout folder exists (I don’t know how it got there) and
appears to be fully populated. However, there is no SketchUp folder in
Program Files or Program Files (x86). I just attempted to run the installer
for the 64-bit version and then the 32-bit version and got the same error
message for both: “An error occurred while attempting to create.\SketchUp
2015\Layout”

John


#17

I just tried installing both the 46-bit and 32-bit versions after turning
off my antivirus. Same error results.


#18

Do you know if you have any Hard Drive buffering set on aggressive settings ? (The HD may be caching disk writes, and the installer is speeding ahead and leaving the hardware “in the dust”.)

There was also another issue where Windows file system buffering was discussed. (The system saves up tasks to do at the next idle time, and code that expects things to get done faster has problems. I find myself very often hitting the F5 key to refresh Windows File Explorer when it falls behind.)


#19

No, I don’t know anything about HD buffering settings. I’ve never done
anything with them myself. But I’ve never had any problems with system
buffering.that I know of.


#20

Well it seems like Windows is not returning true that the directory has been created, when the installer is checking if the directory creation has succeeded. The system has queued “housekeeping tasks” and is not yet ready to report that the directory has really been created. So the installer just bails out with one of it’s built-in error codes.

One thing you might do is start the installer, and when the first confirmation dialog appears, go back and close the Explorer window (and any other open explorer windows.) Then proceed with the installation.