Unable to Install SketchUp Make 64 bit version on Windows 10

I’m running under admin mode and the installation process terminates with a message about an error but no explanation what the error is. It just says the install ended prematurely.

What is the error message?

I wish I could cut and paste but here goes …

“Sketchup Make 2016 (64 bit) Setup Wizard ended prematurely because of an error. Your system has not been modified. To install this program at a later time, run Setup Wizard again. Click the finish button to exit the Setup Wizard.”

And before you ask, I am running as system administrator. It is not very informative.

Being a ‘user’ who has ‘admin-powers’ when installing SketchUp is not the same a choosing to ‘running as admin’.
Select the installer’s exe icon and use the context menu to do that…
Any improvement ?

I had the same issue after a failed installation. Maybe this could help? https://help.sketchup.com/en/article/36209
Way back I solved the problem by deleting anything that I could find in the registry that had to do with Sketchup, but there is a risc by editing the registry manually.

Actually that’s exactly what I was doing … Running as Admin

Any other ideas? Like I said the error message gives me nothing to go on …

SketchUpMake-en-x64.exe is the name of the file. I am running numerous other 64 bit programs …

In desperation, I tried running the install in compatibility mode and I got exactly the same behavior

Also when I downloaded Sketchup, the site selected the 64 bit option and did not give me the option to go 32 bit

Try uninstalling SketchUp.
Then find the previously downloaded 64-bit installer exe file’s icon, and right-click > context-menu > 'Run as Administrator…'
Now retry and see what happens…

I can’t uninstall it because it never installed it in the first place.

I tried clicking the link and install as administrator but I got the same error

I deleted the installation file and downloaded it again, ran as system administrator and I got the same error

I was able to install it on my MacBook Pro but I like the larger, dual screen setup on the PC and would like to work there most of the time.

Are there any logs I can check or other things to try? Am I the only one who cant install Sketchup in Windows 10???

Well I have, and thousands others have too !
So there must be something we can fix…

When you say, ‘ran as system administrator’, please expand…

Did you actually select the installer exe’s icon and use the context -menu item ‘Run as administrator’ ?
Being a user with admin-powers or as an admin will not necessarily produce the expected results…

Please retry, following my steps exactly as I outlined earlier…

I tried to install Sketch up after change to Windows 10 on 64bit computer.
Locks install window for 5 min. or so then gives the following message

C:\Users\Boss1\Downloads\SketchUpMake-en-x64.exe
The service did not respond to the start or control request in a timely fashion.

Also messes with the registry for GPSvc so that logins to non admin accounts no longer work
Logins for accounts with admin privilege give message

‘Windows cannot connect to the group policy client service GPSvc’

Tried in an admin account , then tried ‘run as admin’. with same results.

Previously installed earlier version under W-7 no problems.
Installed 64bit Pro trial version my laptop. Seems OK but who knows what will happen when trial ends.

any ideas ??

I am attempting to install sketchup 2017 and its telling me I am running a 32bit operating system. I am attempting to install on a surface pro x running windows 10 64bit. Any ideas?

The issue you have, I believe, is the processor is an ARM, which is more of a mobile processor.
From the FAQ

You can install 32-bit (x86), 32-bit (ARM32), and 64-bit (ARM64) Windows apps that aren’t available in the Microsoft Store in Windows. 64-bit (x64) apps won’t run. Peripherals and devices only work if the drivers they depend on are built into Windows 10, or if the hardware developer has released ARM64 drivers for the device. It’s a good idea to check whether the hardware developer has published a version of the driver that runs on a Windows 10 ARM-based PC.

So I am able to install and run Sketchup for Schools. Why am I unable to install and run make2017? It says the school version must have a 64bit as well?

SUfS is web based, and your processor runs web browsers.