Unable to Install trial version of SketchUp

I have Windows 10, 64 bit.Today I downloaded the trial version of Sketchup Make (or Pro). The file that got downloaded was SketchUpMake-en.exe.

After confirmation to allow access to the installer to make changes, it shows a brief progress bar, and then the installation terminates with a simple error “Access is denied”. Though I am the administrator user on my laptop, I still right clicked on the filename, selected “Run as Administrator”, and yet again I get the same error. What is wrong here?

Some points…
a) My OS is Windows 10, 64 bit
b) The installer shows that it’s 32 bit software
c) I’ve 8 GB RAM, and half a TB of free space.
d) There are no other problems or malware on my system

Help please!

Hello! Have you tried downloading the 64-bit version and trying that one?
Here’s the link - SketchUp Product Downloads

Check to see if there is a “sketchup_install” directory in your TEMP directory.
Sometimes the installer chokes if there is already such a folder existing.
Sometimes the installer chokes if permissions on this folder are not allowed, or restricted. (Check permissions via folder Properties.)

@VahePaulman, thanks for pointing to the 64 bit version. I downloaded that 121 mb file - filename was SketchUpPro-en-x64.exe. Unfortunately, even with this 64 bit installer, I’m getting the same error reported earlier, even when specifically trying with ‘Run as Administrator’.

@DanRathbun, I looked into your suggestion as well. Since I was not sure which is the correct TEMP dir in my machine, I typed %TEMP% in Win+R command line and Explorer opened C:\Users"MyUserName"\AppData\Local\Temp dir (same with %TMP%). In this folder, I searched for a “sketchup_install” dir, but did NOT find any such dir (or anything resembling).

I had even tried to run it with various other options (like a different graphics card, Win XP SP3 compatibility) via Troubleshoot compatibility. Still I got the same error everytime :frowning:

Any other suggestions please?

rename the file extension of the downloaded setup routine from .EXE to .ZIP and open by double-clicking or an archiving application.

Rip off the “SketchUp2016-x64.msi” (64 Bit) or “SketchUp2016-x86.msi” (32 Bit) to e.g. your Windows desktop and launch by “Right-click > Run as Admin…”.

YES, that is the correct TEMP folder location.

To check it’s security permissions you need to either:

  • right-click the TEMP and choose “Properties” in the left folder tree pane, … or
  • if within the TEMP folder, choose “Properties” from the “Organize :arrow_down_small:” toolbar button.

Then switch to the “Security” tab and select each one of the “Group or user names” in the top list, and verify all the permissions are “Allow” in the bottom “Permissions” list.

The other possibility is that access to your registry is denied, and the installer cannot create registry keys and attributes.

@sketch3d_de: Thanks much for the suggestion. This worked finally :slight_smile:

However I have now a different problem. After the installation was completed, I tried to open the Sketchup 2016 program. However I get a license error as below:

Licensed to: SketchUp Pro 2016 User, Expired

Am surprised, I just installed it, and its supposed to work for 1 month atleast, and even after that it is supposed to work with limited functionality. Why then I’m getting a license expired error?!

How do I fix this license error now?

the SU Pro version runs 30 days as a trial and then ceases to work.
the SU Make version runs 30 days as a trial of the Pro version and then decreases to the limited functionality of the Make version.

The terminated runtime might be created by your several installation attempts.

Try if launching SU by “Right-clicking > Run as Admin” helps, if not uninstall the Pro version and install the Make version.

Installation and first launch always by “Right-click > Run as Admin”.

Now it runs well.


This simply is not true. I ran the Make version and it gave me 30 days of Pro, then said the license is expired and to download Make. Make says it is downloading but nothing happens. I tried this multiple times. I then went to a different computer and downloaded Make again. Again it gave me a 30 day trial of Pro, which I don’t want, and said it would revert to Make at the end of the 30 days. AGAIN — I can’t get Make (or anything else) to load. Does ANYONE, EVER, get a free version of Make? I went to the trouble and expense of going to Bootcamp in Steamboat Springs. I learned a lot, but IT’S USELESS IF I CAN’T GET THE SOFTWARE!!

Jack, if you indicate you’re going to use SketchUp for personal use you should get the SktchUp Make with the 30 day pro trial as sketch3d_de indicated. If you don’t indicate that, it will take you to the Pro download. Find the original installer that you downloaded to see which version you got. It’ll be very clearly indicated in the file name.

At this point you can download SketchUp Make here. If it starts with the Pro trial, you can disable it. See this thread for instructions. Substitute the right version number.

1 Like

I don’t know what it means to “find the original installer,” but I used your link and was able to download Sketchup Make without any trouble. I wish it hadn’t been so hard to find this site, but I’m happy I finally got there and it works. Thanks.

I’m happy you got it installed. Normally most people don’t have any problem downloading and installing from the SketchUp Make download page.

Oh well, you should be off and running now.

This [quote=“jfmonahan, post:10, topic:25217, full:true”]This simply is not true.[/quote]

This is exactly true.

The “hard to find” SketchUp download page was already linked by me above.

I for one would like to know where you were trying to download it from and failing. It’s a simple matter of keeping your computer safe in this hacking world to ONLY download a product directly from that company’s web site. Please tell, what were you trying?