Window Components stuck in wireframe?

Hello,

I’ve been following some tutorials online and somehow my windows which I created one of in a group, then made it a component to copy it to other areas of the house are now only showing in wireframe mode.

I’m not sure what I did to make that happen, but how do i turn it back so it has faces? I was in the process of learning to add materials to faces but can’t figure this out!

Any chance you painted the component after you made it a component? If so, your component might still be the default color. You should open the component for editing and paint the faces there to ensure all instances of the component update as well.

By wireframe do you mean it’s see through and you don’t see faces, or is it just white?

There’s no face on it, that window I just placed to show the difference between the smaller window on the left and the door on the right.

Here’s another photo of window in place that is see through, even clicking it to select it and open it shows the wireframe with no face so I can’t apply materials.

Can you upload the component .skp file with missing faces? It will probably just drag and drop into your next post. Or use the 8th icon Upload above where you write your post, and select the file.

Is it only that component which has apparently no faces? If so, you’ve probably accidentally deleted them when trying to edit the material/texture on the faces.

Try opening the component for editing, and use the line tool, or the rectangle tool, to redraw one or more of the edges with no face. That should recreate it/them.

But without the model itself, we’re guessing.

1 Like

Yea, for sure! Here it is.

Yes, it’s only this component, I was working on the roof and other parts of the house and when i came to adding materials, my windows looked like this.

windows.skp (283.0 KB)

Now I can see what happened.

You are using tags incorrectly and have applied tags to faces, using a tag 1F that’s turned off (invisible).

So no faces are showing, but they are present.
This:

Versus this:

It cause endless problems to the inexperienced, and even confuses the experienced if you tag ANY ‘raw’ geometry (edges and faces).

Just DON’T!

ONLY apply tags (layers in older versions of SU) to objects - groups, components, dimensions, or text for example.

Leave edges and faces (Untagged), leave the pencil icon for the Default tag at Untagged (or Layer0 for versions before SU 2020).

2 Likes

Ah, understood! Thank you so much John!

I’m following a Skillshare tutorial and was working with their file which had these tags, but I understand now that faces can be applied to different tags even if the object is tagged differently.

Thank you!

You don’t ‘apply faces to tags’. You ‘apply tags to objects’ (NOT faces or edges).

Use tags to control visiblity of objects. Use scenes to save sets of views which can differ in what objects are visible, where the scene is viewed from, whether to show hidden objects or hidden geometry, make section cuts visible, etc.

ONLY components and groups separate geometry. Tags (formerly layers) ONLY control object visibility, and if applied to edges or faces especially ones with tags turned off, the invisible geometry can stick to or move with visible geometry you are editing.

1 Like