Why won't my component play nicely with Slic3r?

My component (attached) seems to meet all the requirements for a successful 3D print -

  • Faces all in the right direction
  • Reports as a solid component
  • Solid Inspector 2 says it’s all shiny

But, when I export the .stl and import it into Slic3r, the 3D Plater view looks fine, but the 2D shows nothing, the preview looks weird (attached), layers sort of works, but doesn’t show many layers, and it reports the print will take 28s, which can’t be right.

I have sliced it, produced the G-Code output and tried to print it, but nothing really much printed, and indeed it did seem to take about 28 seconds.

I tried going down the route of uploading it to 3D Warehouse, to select it as a printable part and take advantage of their facility to ensure it will print, however that’s not playing nicely either.

Any thoughts? Ideas?


Radiator cap.skp (212.3 KB)

My guess would be tiny faces in SU. My suggestion would be to draw it at 100X then scale it down.

Have you modelled in inches or centimeters and the slicer is interpreting your units as millimeters?

As @Anssi suggested, the volume of 1,39 mm³ shows a scale issue with the slicer import.

I’ve yet to check, but that is the most likely explanation.

I’ll get on the case in the morning.

Thanks for taking the time to reply.

Yep, the most likely explanation.

Thanks for taking the time to reply.

Thanks Dave

I’d already picked up on the dangers of that and drew it at 10x, having first created a component copy. Worked a treat.

Somebody nailed my problem in a another forum - I’ve drawn it in CM but Slic3r thinks it’s in MM. I’ll be on the case in the morning.

Thanks for taking the time to reply.

Or Anssi 5 posts back an hour ago :wink:

1 Like

Indeed, which I acknowledged to him, with thanks, at the time.