Why will SketchUp not open a simple dwg file?

I cannot seem to open a simple dwg file in SketchUp. I try to import it into SkectchUp and I keep getting the the answer that it cannot open this type of file or it’s not in the correct format. Can someone tell me what is wrong.

Are you using Pro ?
File > Import…
Choose DWG from file-type drop-down list and set Options to suit the CAD settings, select the DWG-file and Import button…
Does the DWG file open in CAD ?
What version is the DWG ?

Sorry not to get back sooner. I’m not sure if I had Pro or not but uninstalled it and was going to back and reinstall to see if that was causing a problem. I have Autodesk DWG Trueview 2017 on my comp but for the life of me it’s frustrating to work with. I’ve never used it before. As far as the file version I’m not sure about that either. It’s just labeled SC8. I got it from an email friend of mine in Iowa, he owns the copyrights to it so I’m kind of skittish about handing it over to someone else to work with me on it if you know what I mean. I can try to reinstall SketchUp and import the file again to see if that works. I’ve also downloaded but have not activated a trial version of ZW CAD 2017. I just need to get some detailed measurements off this file then I no longer need it.

Hi I had a problem like that, I think I closed sketchup and re opened and it worked. I use draftsight to manage dxf/dwg which is free. With this you can save your dwg in different formats such as autocad 2010 (I know this imports into sketchup). Hope this helps?

Thank you Thorleyian,
I’ll have to try that later. I’m very busy at this time of year, also I’m not used to a lot of the software I know will open this file and have never used most of it so it takes me some time to get the feel for new things. But that you again for the info. I’ll look up draftsight this eve and check it out.


July 23

Hi I had a problem like that, I think I closed sketchup and re opened and it worked. I use draftsight to manage dxf/dwg which is free. With this you can save your dwg in different formats such as autocad 2010 (I know this imports into sketchup). Hope this helps?

Visit Topic or reply to this email to respond.

To unsubscribe from these emails, click here .

Always a learning curve isn’t it! You should be able to open the file in draftsight and then save as, you go to the file type drop down menu and there’s a massive choice to choose from. You won’t need much more knowledge of the functionality than that really. Autocad 2010 format should work if not just save it as another type and try again(keep a copy of the original). Let me know how you get on.

Thank you again Ian,
It may be a bit, may be tomorrow or the next day. Garden really has me busy at this time.

I downloaded draftsight but when I tried to save the file like you say, there was no such format to save it like that. So I just saved it in the format that was automatically there. It just shows up as a dwg file in my docs. I downloaded sketchup again and will see it it all works out tomorrow.
Thank you for your help, I’ll let you know what happens.

This drawing will open in anything but sketch up I even downloaded Draftsight and can’t find the correct format to save the file in and import it into sketch up as Ian was telling me. I haven’t used sketch up i a long time but do remember how to open files to get measurements and all. I have two different free tryout versions of software to open this file with but can’t find the correct settings to save it in either. I’ve tried to import the file into sketch up and try to open it but always get a pop up window that says, “This does not seem to be a sketch up file”, or This is not a sketch up file and will not open it. No I’m not using pro I can’t afford it.

SU Make does not have the ability to import dxf or dwg once the ‘Pro’ trial expires…

if you are using it for non-commercial activities, you can install a ‘third party’ extension to add it in…


Sorry I’ve got my wires crossed! It’s r2013 drawing dwg or r2010 drawing dwg both are autocad format.

Cheers Ian

Thanks Ian,
I’ll have to try that later today. Out early this morn getting things done before it gets hot.

I’m only using it for myself. I’ll have to go back and uninstall the version I have then get the trial version and add the extension you speak of.
What extension do I need to look for if you don’t mind telling me ?

This makes a huge difference in the answer to your problem. You might have mentioned it at the beginning and included it in your profile. It would have saved everyone including yourself a lot of time.

Dave ,
I did mention it to one of your members saying I would have to uninstall the one I have and download the trial version of pro, thank you.

you only get one shot at the trial…

if you already had it you need an extension, no need to uninstall anything…

if you haven’t had v16 Make with the 30 day Pro trial, then it has it’s own exporter, no need for another…

you can also have multiple versions of SU so there is rarely a need to uninstall any, unless you had ‘Pro’ trial and now need ‘Make’…

can you clarify exactly which version of SU you have?


All I need is the version I can use to get measurements of this drawing I have. If I download the Pro trial version I need to import that dwg file and have it open in SU, so far all SU is telling me in a pop up window is, This doesn’t seem to be a SU file and it will not open it.

A DWG file is not a SketchUp file so trying to use File>Open in SketchUp will give you the message you’ve been seeing. To import a DWG file into SketchUp, use File>Import and select AutoCAD Files (*.dwg, *.dxf). You have to have SketchUp Pro installed for that option as has been written several times already.


Thank you Dave.

help why my sketchup missing command to import any dwg files? how to fix that ?