Can't open DWG File

Hello.

My friend sent me a dwg file but I can’t open. Import Filed.

This is DWG File. Stacja Chmielow dojscie_210105.dwg (12.9 MB)

Opening the file in Notepad++ it starts AC1032
This means it’s an AutoCAD v2018 file.

Your profile says you are using SketchUp v2018, so perhaps its importer is not up to date ?
I’ve tried it in v2018 and it immediately fails without useful error messages.

With the next 3 newer versions of SketchUp it starts to import, but hangs it at about 17% processed - and I see that happens just after it’s tried to import a block with a name containing Polish characters…
So perhaps it contains rogue non-ASCII characters, which are causing the importer to hang.

Perhaps @colin has a comment ?

I have started the import in SU 2021. It is going very slowly and using 100% CPU, but appears to be making slow progress. About 2/3 done after about 25 minutes… I’ll report again when/if it completes or fails.

My v2021 [PC] import stalled at 17% and stuck there until I cancelled it…

I also tried a couple of free dwg viewers, and neither of them opened it successfully. They didn’t go into a non-responding state, just showed a blank page.

Sounds like a number of reasons to go back to the colleague and ask them to fix the file and maybe save it as an earlier .dwg version.

DWG TrueView [by AutoDesk] does open it eventually [A building and some rail-tracks], but there’s not much you can do thereafter, so there’s something in the file breaking SketchUp’s Importer ??

Perhaps try getting your colleague to save a DWG down to a very old AutoCad version, purge it etc and give it to you to try again ?

ODADrawingsExplorer opened it and showed this:

I have no idea why SketchUp stalls while attempting to import, nor why the other viewers I tried showed nothing.

The file does include some Polish characters, I tried replacing those, but then the file failed to import.

BTW, saving as an older version DWG is something that TrueView can do.

For me TrueView opens it quite fast. Opening the DWG gives me two error messages, first , that it has been created with a Student version, and second, that the file was created by a non-Autodesk application. What was used to create it? At first sight it might even be SketchUp. One old exporter produced the “student version” error. I have got the same from Archicad. I guess that a similar export library was used.

Importing it into SketchUp stalled first at 17% and a bit later an “Import failed” message appeared.

A friend sent me a revised version. Now it starts. I don’t know what he changed.