Downloading issue

installation

#1

When I open the drawing file for a specific dwg. I get a message about a newer version of Sketch up Make but it wont install. I click on the NEXT box but nothing happens. I have previously installed the latest version (Sketch up - Make 2017)
& it works for most dwg. files but not all of them.


#2

SU Make , The Free version which appears you now have does ,not have the capability to import dwg files but ,when you installed SU initially you get a 30 day free trial of Su Pro which can import dwg format and after the 30 days it reverts to SU Make the free version.
There is now a plugin (s) you can used called TECLAsoftware_Import_DWG_v1.0.2xx and
TeighaFileConverter_QT5_vc10dll


#3

My problem has nothing to do with imported files. I try to open an existing dwg. of my own creation and a message appears about a newer version of SU. The original
file doesn’t open.


#4

@mac7595 Is trying to let you know that SketchUp Make will not open a .DWG. You have to upgrade to SketchUp Pro to do that.


#5

My apologies, I had no intention of implying that I had imported a DWG.
All my files are my own work. Why some files wont open I don’t know.
As I stated some files display a message about the latest version of
SU while others open normally.


#6

When you state all files are your own work I assume you mean they are all skp or may be skb files. You really need to post details about what is done assuming you are dealing with a dummy like me.
SU typically is not upward compatible which means if you are trying to open say a 2017 file in 2016 it will not open but opening a 2016 file in 2017 will work usually ( some times changes are made that can present problems also)
May comment about opening a xxxx.dwg file still stands ( note the location of the period!) even if it is one you made. When you incorrectly use dwg. that can leave one to assume you are implying some what a file type.
If you have backup creation set in SU preferences it will not open that unless you have correctly set the file association in widows but I guess from the reported issue that is probably not the case.


#7

the native file format of SketchUp has the file extension .SKP (or .SKB for the Backup files). DWG/DXF data is the industry standard for exchanging typically 2D CAD data and needs to be imported (not opened) to be used by the SketchUp Pro version only (non-commcercial Make version does not have a DWG/DXF import).


#8

I wonder if this is a case of the OP using dwg as an abbreviation for drawing. It is confusing in the context.


#9

I think you mean dwg - victim of AutoCorrect?


#10

Yes. Grrrr! Fixt.


#11

On top of that is the question of what exactly the message is?
I suspect it is the message saying the model was created in a newer version…
Rather than, There is a new version of SU available…
But I’m only guessing.
Could it be that the OP made some models in 2017 then downgraded to 2016, and therefore they wont open.


#12

install the SU 2017 Make version parallel to your existing version again, open the affected SKP documents with SU v2017 and do a “File > Save as…” by selecting the older SketchUp file version required (see dropdown list):


#13

I thing you mean think.


#14

Touché! Also fixed


#15

Hello Aaron

I should have called everything a skp file in stead of a dwg. When I open
most files
there is no problem but with a few i get a dialogue box telling me to
download the latest
version of SU. I follow the instructions but when it comes to selecting the
NEXT button
nothing happens. Earlier this year I installed the 2017 version of SU so
why does the
dialogue box appear in the first place ?

Regards, Ken


#16

A DWG is a specific file format, so I think that was the confusion. A file produced by SketchUp is an SKP.

I;m not sure exactly what you are seeing, but you can just hop over to the download page and grab the most recent installer for your operating system.


#17

Could you post a screen shot of the dialog box you are seeing? Seeing the exact message would likely be very helpful.


#18

Hello Aaron

I tried the “DOWNLOAD PAGE” but same result, I get to the dialogue box with
the choices “CHANGE” “REPAIR” “REMOVE” The repair button is
hi-lighted
but nothing happens when I click on it. Why isn’t the change button
hi-lighted ?
Confusing or what ? I’ve been using Sketch-up Make for years it seems
without
any glitches.

Regards, Ken


#19

The up arrow button above gives info on what files you can attach to you post, suggest no jpg for this problem there is probably not enough info in them. You can attach a file you cannot open without opening it. Then do same with one you can open ok
< Confusing or what ? I’ve been using Sketch-up Make for years it seems
without any glitches.> I would guess there is not one of the sages in your same position


#20

Hello

It seems there are many users of SU having problems because of updates to
Windows10. When it’s all sorted out I’m sure my SU will operate normally.
As for the files that wont open I have hard copies. They are not large
files
and they are of no monetary value. Thanks everyone for your help.

Regards, Ken