Why my SketchUp use a lot of memory?

When I using SketchUp to do office interior fitout drawing, basically just drawing some simple walls and putting office furnitures in there, most of the furnitures are the same, I just copy and paste probably 20 times in a floorplan. The used memory was quite low at the beginning, but it will go up to 12GB or even more after I use it for a hour or two, and it works very very slowly, unless I quit the SketchUp and re-start it again, and it becomes normal again. This happens even the Vray is disable.

I am using 2014 iMac, i7 4.0G CPU, 8GB memory, AMD Radeon R9 M290X 2GB, OS X Yosemite.

I didn’t turn the Anto-save on, I didn’t tick maximum texture size, and I tick use fast feedback and use hardware acceleration.

When I use Vray for SketchUp for rendering (usually the 3D files have more details), at the beginning all goes fine, but sometimes the memory will be used up to 60GB and the rendering stop and I can’t save it or pause it or re start it, all I can do is close the programme and lose anything.

Is there anyone knows what the problem is? Thanks heaps.

I don’t use either Vray or a Mac, but I seem to remember that some older version of Vray had this kind of problems. Have you tried disabling Vray? What size are your model files?


this is a known Vray issue…
reports indicate that Vray3 for mac has been written to minimise some of the problems…

Thanks Anssi,

Every time that I do the base sketchup drawing I will disable Vray, but the memory still use up to 12GB after 1 or 2 hours using. Those sketchup files usually are about 150MB.

When I am using vray to render, the memory use might go up to very high, but it doesn’t happen every time. Sometimes it works fine, sometimes the machine pause itself as memory goes too high. And I believe I am using the lastest Vray version.

This is still a problem! Even after the latest update Sketchup feezes up the whole system after a while, using up all memory. I have experienced this for a long time now, and if you ask me it’s a tottal skandal!