Why is this happening?


#1

First of all i want to say sorry if i can’t say the exact terminologies but i will try my best on explaining what is my problem.

So i have a very serious problem regarding on zooming into a surface or object. I know that when you point your cursor on the object/surface you can zoom in/zoom out easily and faster. But sometimes when i accidentally point my cursor on non surface/object area then zoom out/zoom in i can’t turn back on the same point. And when i orbiting to locate the center of the axes i found out that i’m so far in the center where my object is located also. Then i tried zooming in again but after several zooming my computer FREEZE. It happens to me many times, i send a bug splat report on the server many times. And no one tried to response on my problem.

See attached image of my problem,


#2

Which version of SketchUp are you using?
Is this with every file or just one in particular?
If just one file, can you upload the file?


#3

Sketchup Pro 8, It happens in every file and also on my downloaded files from 3d ware house Sir.


#4

Reporting bug splats is for feed back to see if SketchUp needs fixing certain reported issues. If more feed back is needed, they (the SketchUp develloping team members) no doubt will contact you if they can’t reconstruct the issue themself.

Could you upload a file?

You may be using a (changed) template that has some geometry in it way out, far from thge origin.
Some geometry that you don’t even know off. For it seems to happen in all your files.
If so, “repair” your favorite template: = make the necessary changes and save as template

Tip: when starting a new file, create a (few) scene(s) with a view of a close up of what you are working on. That way you can always return to the view if you get lost in space.


#5

@Wo3Dan No, I’m not using a template. I always create a new one.

Now i know, i can also use scene(s). Thanks! (Y)

See attached file of my actual model.FINAL STORAGE PLAN.skp (2.0 MB)


#6

I would like to add after opening my drawing, point your cursor on the model try to zoom in and if you are very very near on the model point your cursor beyond the model zoom in again ,continue zooming in until you can’t see the model then try to orbit … there the problem occurs… you will see you are very far in the model and when you zoom in the computer freezes.


#7

You do have a copy of most of the colored model as a previous one (not colored) in another quadrant of your modeling space. Can’t you just delete that? Now orbiting involves “dragging” all geometry into the operation. This could be the cause of your issues.
Also move the model close to SketchUp’s origin. This helps.

Also you do have lots of repeated groups, no names at all. This calls for working with components.
And when working with grouped geometry, bring in some relevant (named) layers to have these groups and/or components assigned to. Then you can create scenes with certain layers on, others off, depending on what you are working on. This makes modeling life much easier.

Do not assign basic (ungrouped) entities to layers other than Layer0 !


#8

When you zoom, SketchUp changes its behavior depending on whether your cursor is on an object or not. If not, it assumes you want to move rapidly through empty space and can take you a long way in a hurry! To restore sanity, use the zoom extents tool. Then zoom more carefully, either on an object or in smaller steps.


#9

Go to Camera > Zoom Extent.

Make Camera > Previous a keyboard shortcut. It will take you back to your last 2 camera positions.

Set up at least one Scene with camera position saved. Then clicking on the Scene tab will bring you back to one of your model views.


#10

Thanks for the replies guys. I will try it all.


#11

I know this is an old thread, but I’ve fought this issue on all versions of SU going back to 7 (including 2015) and I think I just figured out at least one trigger. It seems to stem from text labels and dimensions being visible in your model while zooming. Of course, there may be other factors involved, but this is the only one I’ve been able to verify so far.

The issue that was originally reported surfaces while zooming. All of the sudden it your model disappears and SU seems to get lost. The image posted by SketchupKage01 is exactly what you’ll see. At this point, the processor kicks into high gear, basically freezing the application while it sorts out the video. This process can take 15 seconds to 20 minutes depending on the model. Very frustrating indeed! Once the processor settles down and SU starts responding again, you can hit the Zoom Extents function to get things back. Sometimes you’ll have to hit that function twice in succession to make it work, but finally you’ll get your model back into your field of view.

Be aware that if you happen to try zooming immediately after SU resumes, you’ll likely restart the process with a freeze…so go right for the Zoom Extents function once you notice SU has settled down or you’ll have to wait again.

Now the good news…

To avoid this issue with your model, simply create separate layers for text labels and dimensions and keep them normally hidden. Only unhide when you need to work with them.

For me at least, this workaround prevents the issue. Hope this info helps someone else.


#12

This just happened using 2017.

A quick fix was to delete the labels, highlight all remaining area, and copy and paste it to a new document.

All my work was just how I left it.

Cheers