Can Only View Model in Top View

bug
topview

#1

I have a problem with my model in SketchUp. When I click on Zoom Extents, the model disappears. I can get it back, after clicking Zoom Extents, if I Pan a bit, and Orbit a bit, and use my mouse scroll button to zoom out a lot.

However, I am only able to orbit the model to top view. Orbiting to any other view causes the model to disappear again.

Not sure if anybody can help me fix my model so I can go back to adding items again. I am not keen to have to redo the floor plan again. :frowning:

Thanks in advanced, everyone.


#2

If you can upload the model, we can provide a definite diagnosis, but here are some guesses.

You don’t say whether you are using perspective or parallel projection. Particularly in parallel projection it is possible to encounter clipping in the display as you orbit, zoom, or pan. If you search for “clipping” on the SU help or forums such as this one, you can find many discussions about clipping and how to mitigate it.

When zoom-extents causes a model to disappear, that most often means there is some bit of geometry placed far away from the rest. Zooming out enough to view everything at once makes everything too small to see! This problem is especially common when the model is imported from CAD, which has a tendency to place model contents far from the origin.

When orbiting, you often have to be careful to place the cursor over some part of the geometry before you start the orbit. Otherwise wild and large swings can occur because SketchUp can’t figure out how far behind the screen you meant to use as the center of rotation.


#3

Do you have guidelines? If so, Edit > Delete Guides and try Zoom Extents again.


#4

Hi! I am using perspective. I just downloaded the app, and haven’t tweaked settings yet, so I’m not on parallel projection. What tool should I use to upload my model?


#5

Not using guidelines, but I just tried this tip and still have the same problem.


#6

In the reply edit window of this forum, either drag-and-drop a file into the window or click the upload button at the top:


#7

2nd Floor.skp (395.4 KB)

@slbaumgartner thanks! I’ve uploaded the model here


#8

As I suspected, your model had somehow gotten a Text object located an undefined distance from the origin of the model. This entity causes most zoom, rotate, and pan operations to go nuts! Here is a version with that object deleted

2nd Floor.skp (291.0 KB)


#9

Thank you so much!


#10

While it’s good to get rid of those distant objects, there’s some useful tips to restore good camera positions. Create a Scene, with camera position saved. That way you can go back to a known location with the click of a button.

Also Camera > Previous will go back to you last few camera positions. I’ve found this to be so useful, it’s been set as a keyboard shortcut in Window > Preferences > Shortcuts.