Why Is The Deauthorize All Button for Licenses STILL Not Working?

Guys - this is starting to get frustrating.

Sorry to bug you @colin , but you seem to be the guy that knows who to talk to on this kind of thing.

I occasionally have to switch between a desktop PC and my Laptop for various reasons - my understanding is that my SketchUp Pro license should work on 2 different computers, so this shouldn’t be an issue.

EVERY SINGLE TIME I try to use SketchUp on my laptop, it tells me that I’ve exceeded my allowed activations - I’m only logged in on one other computer, so this shouldn’t be the case.

So then - I go log out on my desktop computer (which I shouldn’t have to do since it’s the only other place I’m logged in), so I’m not logged in to SketchUp Pro on ANY computer - ANYWHERE.

I then try again to sign in on my laptop, which gives me the message STILL that I’ve exceeded my allowed activations, and gives me a button to press to go manage my activations.

I go to that link, and there’s a button under SketchUp Pro that is SUPPOSED to deauthorize all my licenses on all my computers, I click it, it tells me that all licenses are deauthorized

I try to log in again - I get the same message - that I’ve reached the maximum number of activations and cannot use SketchUp on my laptop, even though I’ve literally logged out of every single computer I use SketchUp on manually AND pressed the deauthorize all button that apparently doesn’t deauthorize anything.

I repeat the process a couple more times to make sure it’s not just a sequence issue on my side and continue to get the “exceeded maximum activations message”, then I get this message both on my Laptop and Desktop computers.

image

So now I can’t even try to log in on ANY computer to use SketchUp.

image

Why after I’ve pressed this button would I still be getting the message that I’ve exceeded my allowed activations? This is a real issue for me, because if I’m traveling or away from my home computer and forget to sign out of SketchUp before I leave, I won’t be able to log in on my laptop and use SketchUp at all.

4 Likes

The trick is to close (all instances) of SketchUp after you signed out in SketchUp.
Then, start SketchUp again (this will force SketchUp to get a new token from the servers with the updated info after the deauthorisarion of the devices)

No other software package I know has so many licensing-related issues raised on their forums.

8 Likes

Nope - I closed all instances of SketchUp, restarted the computer, and came back 5 hours later and it STILL doesn’t work.

It let me log back in on my desktop PC, so I suppose I should be grateful something works, but this is really frustrating.

Since 21, or another way to put it is since the beginning of the subscription model, I have had licensing issues as well. I find SketchUp is often asking me to log in again when I already am, spontaneously logging out, exceeding the authorized devices, not working offline as advertised and other shenanigans, its getting super annoying. I’ll be waiting for someones version to lock up due to licensing issues mid-presentation at Basecamp. I don’t have any magic bullets but I thought I read that all versions of logged in “SketchUp” count against the authorization limit, including the phone app or ipad app? Is that true? Still deauthorize all should take care of this.

Oh man - I was hoping this would be it, but nope. I logged out of the Ipad version and I’m still getting the authorization message.

The whole point of having a “deauthorize all” button should be to avoid this situation, but here I am this afternoon still unable to use SketchUp on my laptop :man_facepalming:

2 Likes

I’m at Heathrow airport, heading back to Boulder. Only just saw your post.

Each version of SketchUp you have signed in on counts. A this point you could have 2019, 2020, 2021, and 2022, all working and signed in on a single machine. That will seem like four sign ins.

The deauthorize all, sign out, sign in, should have worked. One recent change is that reopening SketchUp won’t immediately attempt to re-authorize SketchUp. Hence having to sign out and in again for 2022. With older versions they automatically would re-authorize.

Which would mean that if you dipped into 2019, 2020, or 2021, it will have taken one of your 2022 spots.

Can you look on both machines, and see what versions of SketchUp were currently signed in?

I believe that mobile devices have their own count, and won’t take away from your desktop allowance.

Thanks @colin - sorry to bug you while you’re traveling.

As far as I can tell, the only place I’m logged in anywhere is in one location on my desktop PC. I’ve checked 3 other computers (current laptop, old laptop, and work laptop) to see if I accidentally might have left something logged in, but I’m not seeing anything.

I went back through the deauthorize/reauthorize/signout/sign in process and it still didn’t work. I even went so far as to uninstall SketchUp Pro off my laptop and re-install it, and it still didn’t work.

At this point I’m at a loss.

1 Like

Have you used more than one version of SketchUp on your desktop? You would have to open each one and log out separately from each. It’s idiotic, but that’s how the powers that be have designed it.

2 Likes

I get this when I accidentally open an SKU with Sketchup 21 because windows remembered the default application. You may find that you inadvertently opened SU21, and that’s using one of your licenses?

YES, 100% deauthorizing all should solve the problem, but it does not, and it is super frustrating when you are not near the desktop.

I know when I fly to BaseCamp in Canada I will be checking and double-checking before I get on the plane.

I have 2 laptops, as last year was living in 2 places. Now only in one, but use 2 laptops as younger one had issues in the past and had hard disk repaired and windows reinstalled.
Had big problem installing 2022 on one machine. I signed out everywhere and deauthorised everything and uninstalled 2022 ,but on reinstalling 2022 still said I was using too many machines, even tho 2021 still worked.
Eventually, having deauthorised and signing out yet again, I also signed out of google sync as well, resigned in to sketchup, downloaded 2022 again, signed out again, reinstalled it, and this time it worked. But obviously I have to sign out of everything all the time, even using 2 years of sketchup on one machine, which is a pain, but better than it not working.
Liz

There is a file, login_session.dat, that stores some of the session data. Deleting that file can fix some issues. It’s here on Mac:

~/Library/Application Support/SketchUp 2022

and here on Windows:

%AppData%\SketchUp\SketchUp 2022\SketchUp

I went back through and checked every instance of SketchUp I have installed ANYWHERE (as far as I know). They’re all logged out except for the single instance that’s logged in on my desktop PC. Even when I logged out of that one it STILL wouldn’t let me log in on my laptop.

Just tried this - deleted that file - still getting the activations message

Make sure toquit all open sketchup and layout documents for it to take effect.

If you are on windows, make sure there are no SketchUp processes running / restart your machine

I’ve done all of this, though SketchUp processes on my machine shouldn’t matter anyway unless I’m actually logged in.

I would assume that the “SketchUp web helper” process is the process that is actually logged in/cached and it may not attempt to get the latest local data until it boots.
It’s not uncommon for me to see 10 of those running on a machine (I don’t know why that happens)

I just recalled that I did have a reseller of ours who actually had multiple subscriptions from multiple sources including some very old beta group stuff and she had to revoke them from herself across the multiple subs before it sprang back to life. I suspect you could be in a similar boat to her Justin

I’m in the same boat @JustinTSE. I just got a computer for work and I have a laptop that I work remotely for, i tried to sign in and received the same message. Weirdly enough for me, whenever I click the link to manage my subscriptions it takes me to the home page. I thought that was weird enough on its own. Worse is when I try to follow the instructions via: Managing Subscription Plans | SketchUp Help when I press “Edit plan settings” it tells me to contact a support email in order to manage (an thus disable) any device. I do not have the ability to wait for a support team to get back to me in 5 business days. I have a job that requires this…
I checked all of my files, I do not have SKU 12, 20, or 21 on either computer. In the library, all of the caches have been cleared and there are no relevant files. STILL DOESN’T WORK.
It’s incredibly frustrating to have to reach out to someone else for something that I should be able to do on my own in less than 30 seconds.

To deauthorize all devices you would go into My Products, and View Included Applications for SketchUp Studio, then Manage Devices in the SketchUp Pro box. You would not need to edit your plan unless you were adding more seats, and as it’s an education subscription that would be done by Creation Engine.

Justin did find out later that he had another subscription, and that he was going into the wrong account. I don’t think you have other accounts, so that shouldn’t be the problem for you.