Why is Layout (2020) not updating its view of my SU model?

I’ve created two viewports on two separate pages in Layout. I’m quite new to using Layout, having only used it a couple of times for simple things in the past.

Each shows a plan view of my model, on two A4 Portrait pages, which I intend to glue together to get approximately an A3 view of the two halves of the plan.

I updated the text in the lower half of the model (as you look at it on screen)

to flip it along Red axis (L-R) to read correctly upside down from right to left, like this:
then saved the model.

Layout is viewing the Plan - version 2 scene from SU. I’ve tried (in this order):

  • clicking on the Refresh icon image in the Sketchup Model part of the Layout properties section.
  • clicking Update in the Document Properties/References section, with the reference selected
  • and even tried removing the link then Relinking to the model.

But the Layout file is still showing the previous version with the text mirrored upside down from the top half of the model, and mirrored L-R:

The text stays stubbornly mirror imaged instead of rotated 180°.

I don’t understand why. I have not edited the model inside the viewport, and it is not showing as Modified.

Layout model attached (I believe it includes the SU model):
Five Kinds of Silence - set.layout (4.9 MB)

Is it relevant that the SU model was saved back to v2016 so that others for whom that is the latest version their computer will run can view it?

Shouldn’t it still update in Layout when the SU file is edited and saved, and I click Refresh or Update?

Looks like you are still not linked to the file you believe you are linked to. The SU file that is imbedded in this Layout has the label in question mirrored (incorrect). I opened the SU file by right clicking the layout viewport, and changed the wording in the SketchUp file. Then the words show correctly in the layout file. If you right click and > relink model reference then select your new file does it then load?

I’ll re-try that. A moment.

Well, I looked more closely at Document Setup and the file was showing as Embedded.

So I Unlinked it, Purged, closed LO and restarted it.

It’s now showing Current as status.

I also clicked Update with the file selected (the FKOS SU file is in the same folder as the Layout file, so ./FKOS.skp should refer to the edited and saved SU file).

Looked again at the Layout viewport.

Still not changed.

What am I missing?

Do I need to do something further, with the viewport selected? If so, what?

PS. Just tried selecting the P1 viewport, then clicking in turn the Refresh icon, and the Link icon. After clicking the latter, I reconnected the FKSOS set.skp file, and still nothing changed.

Did you try relinking to the SketchUp file?

Yes, Dave, several times in two different ways, I thought.

Both in Document Setup and in the Sketchup model panel near top right in the Layout window.

Document Setup is showing:

How can I check if that is indeed the model the Viewports are using? Can they still be stuck on Embedded, but not showing in References?

I’m still seeing this in the Sketchup model panel:

Here’s the SU file itself.

FKOS set.skp (3.2 MB)

In the Layout file, select the Viewport and then right click on it and select > open with Sketchup. What file opens?

When I open (FKOS set.skp) the SU file just you posted, I see the writing mirrored incorrectly in that file. So if that is the one you are linking it will show as backwards in Layout too.

Oh? I wonder how that happened? Maybe the file I was editing wasn’t the file I thought it was! But the timestamp, and I thought the folder I opened, were the right ones.

V late here now (almost 1:30am). I’ll have to wait till tomorrow to take this further. Many thanks for your time.

1 Like

I don’t know why your file isn’t staying linked. What happens if you open the one that is embedded and then use File>Save as… and then relink to this file. Does it remain linked after that?

In the embedded SU file the text is reversed on the lower sections but because of the way you have the text done, correcting it in the bottom part mirrors the top part. I wonder why you aren’t using LayOut’s text for this instead. You’d have a lot better control over it and it would look much nicer. I didn’t do it all but here’s an example.

Do you want the grid on top of the content?

I think as you and others have noted, Layout IS staying linked, but the file it linked hadn’t saved the changes I made to the SU file.

I still don’t know how that happened, but it seems that the SU file I was SURE I had saved, the one attached in a previous post, had NOT retained the changes I had made to reverse the text. So that would explain why Layout didn’t see the changes.

I checked the whole of my hard drive to see if there was another copy of the file, and there is, in a Dropbox folder, as well as my Drawings folder. But it hadn’t been updated since February, and was definitely not the one that Layout had linked to.

So the issued is resolved, but I still don’t know why the save didn’t work. And I did the save more than once, I thought, before trying to update the viewport in Layout.

That was indeed true, before my changes. I made the bottom two steeldecks unique before flipping them L-R along the red axis. Neither change was saved.

Not sure yet. Probably not. I put the grid on top because it wasn’t showing at all earlier - blanked off by a ‘higher’ layer. There’s no face on the floor of the Studio, so it would probably now be ok to uncheck that box.

Maybe you can help me understand that ‘blanking off’?

On the left page, for example, I drew just three lines for a border, round the top, left and bottom, and made it a group. But unlike SU this seems to create a face, which started as a white triangle after I drew the second line, and a full white rectangle when I drew the third line. Should that happen? It seems completely counterintuitive to me.

Yes. That’s supposed to happen if you have Fill enabled in Shape Style. You could select it and turn off Fill. I dragged a copy of it over to the side so it shows.

Ah. That would explain it. I didn’t expect a fill to happen with only three sides. Thanks, as always Dave, for your prompt and expert advice.

1 Like

Because I’ve only just started trying to learn how to use Layout effectively. The lockdown is giving me the chance to learn it.

In the past I’ve always just printed direct from SU, so I embedded the (Flat) text in the Steeldeck components.

And I used SU Screen text to label the output pages.

PS. I think I can use an AutoText entry to pick up the component definition to use in Layout and display it. Will work towards that in future.

1 Like