Why geometry behind camera shows on my elevation viewport?


#1

This happens when the elevation scene in SketchUp is created using the Position Camera Tool instead creating section plane and the viewport in Layout render as vector.

I’ll tray to illustrate the problem in a simple L shape kitchen with Island model (no wall, no floor, no ceiling…),
I used this workflow to setup Scene 1:

  • Set camera to parallel,
  • Select standard view to Top,
  • Place Position Camera tool in some point between the island and the back part of the kitchen, then hold and drag the cursor toward the back part of the kitchen in the green direction (TOP VIEW SCENE4).
  • When the elevation viewport is render in raster mode the result image is as expected (RASTER SCENE 1), but this no happen vector mode because the island geometry shows in the elevation (VECTOR SCENE1).


#2

00


#3

File

simon, Hope this is the correct link.


#4

Yes, that downloaded OK.

I did a little test of my own and was able to reproduce your issue in my own drawing. I confess that I don’t know why that happens. It doesn’t seem as if it should.

I often do kitchen layouts like yours with the same kind of elevations and plans. However, I would not have set up the views quite the same way. I would have created a section between the island unit and the sink run. I think that would overcome the problem.

I wonder if @DaveR or @eneroth3 can figure out what is going on?


#5

I don’t know exactly why this happens. It always has happened and I don’t give it much thought. I would automatically set up the scene so the island wouldn’t be a problem. My procedure for setting up that scene would be to turn off the visibility for the island layer before creating the scene.


#6

The camera clipping in parallel projection mode cannot be controlled reliably. Better use a section plane.


#7

Maybe the Position Camera tool projects the position to the model bounding box (for some reason). Try doing this in perspective and switch to parallel projection once the camera is correctly positioned.

EDIT: I didn’t see this was in LayOut. LayOut’s camera can be quite unpredictable. For some reason the exact rendering engine of SketchUp isn’t used. I have had issues myself in the past with geometry very close to section cuts that behave differently in LO from in SU.


#8

Tank you to all, I thought the problem was on my end.

I normally use a section plane to setup my view, I was in a hurry and I used that method, which was not as fast as I expected.


#9

An SU section plane cannot be cranked so a section cut in the location you need will cut through the return run of units on the right hand wall. For my purposes, that is generally fine. If you want to get the effect of a cranked cut so that the end of the right hand units is visible, @DaveR’s method would be best.


#10

Tanks simon for take your time to point me in the right direction.


#11

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.