Vector is showing everything between me and the elevation I'm trying to look at, but not in Raster...?

I recently discovered the position camera tool technique to create elevations more quickly and seamlessly in Sketchup to Layout.

I have a U shaped kitchen and I want to look at the cabinets on the west wall only. So, I position camera’d to the west while in parallel projection view, and voila! I see just what I need to. I made it a scene and sent it to Layout.

The elevation shows up, but when I change the lines from Raster to Vector and even Vector/Hybrid, the wast wall is now overlapping the west elevation, as if I am looking through the east wall to the west wall. Switch back to raster, and the elevation looks fine. The only problem is that it’s raster. I need these lines to be crisp for clients.

I tried all the different styles for viewing this elevation, but nothing seems to work.

Does anyone know what I’m missing here? Is this is a bug?

Thanks!

Best would be to use section cuts instead of relying on the clipping bug to get the views you want.

1 Like

You might check to be sure you have the most current version of 2022. When first released, 22 changed the behavior of parallel projection views and this clipping plane behavior, with much protest from members here in other threads. I thought a revision was released to addressed that, but I could be wrong. I’m still on 2020 on a daily basis, so I’m not there yet myself.

Dave’s suggestion will solve things, and what RTCool mentioned is why it took a while to reply! I wanted to check if the recent changes would have affected this. They don’t. I tested in 2017, and it seems that in parallel projector, vectors in LayOut show all of the vectors, including the ones behind the camera.

As Dave says, Section planes should solve that.

If you persist in using clipping in your views, try keeping to raster rendering and setting your Output resolution to High. IMO the result in PDF files is not overly coarse. I always also uncheck JPG compression when exporting to PDF.

Thanks for all the comments everyone.

I do have the latest version of Sketchup.
I didn’t realize this was an established bug, but it makes sense.

While Section Cuts work well, I have trouble seeing each elevation in Layout when those section cuts overlap. Am I using them incorrectly? I tried saving updating each, making sure to update each parameter (style, fog/shadows, etc.) but I still have trouble.

Is there any merit to making copies of the model and trying to manually cut each into sections and building scenes form those? seems like a major hassle.

Are you saving scenes in SU? If so use a style that has the section plane off and section cut on.