About those elevations that relied on the clipping bug

For many years now people have complained about seeing clipping in SketchUp. Two of the most common causes are:

  1. You zoom into a scene while in Perspective, perhaps not knowing that the camera has moved into the geometry. You switch to Parallel Projection, and now see horrible clipping every direction you look.

  2. You have a large model, and you are trying to work on a small detail. As you get close the front face or edges disappear. This could happen in Perspective as well.

In 2022.0 there were two fixes. One was to make it be that when you go into a component or group, and if Hide Rest of Model is selected, the geometry that gets clipped is based on what you can still see, and not the full model. The other fix was to back the camera outwards if you switch to Parallel Projection after moving the camera into the geometry. You then can use zoom to look closely at whatever you are working on, and the horrible clipping doesn’t happen.

If you are reading this post you are likely aware of a use case that the fix prevents you from doing: creating elevations without using a section plane, by positioning the camera in a location where the clipping bug hides the geometry behind the camera. Hopefully you have been able to try section planes as a better solution to the problem, but you may have some older models where many of your scenes are using the clipping technique, and that would be a lot of section planes to have set up.

In SketchUp 2022.0.1 we have adjusted when the clipping fix is applied. Now, if you do the #1 steps from above, the fix still happens. But, if you use the Position Camera tool to intentionally place the camera into the middle of your scene, the fix does not happen.

After placing the camera, and switching to Parallel Projection if you were not already set to that, doing an orbit or a look around, or choosing a standard view, will then apply the clipping fix. Previously those actions would have led to the horrible clipping.

So, if you need to take advantage of the clipping bug as a way to get elevations, this would be a way to do that:

  1. In Perspective, orbit to get a clear view of where you want the elevation view to be seen from.

  2. Choose the Position Camera tool, click, then drag, from the point on the ground you want to view from, and drag in the direction you want to look.

  3. Change the camera to Parallel Projection.

  4. Use only the Pan and Zoom tools to center and scale the elevation.

You could start with Parallel Projection and not have to do step 3. An advantage of being in Perspective is that it would be easier to get the camera to a place where you can clearly see the ground where you want to view from.

This change in 2022.0.1 also allows the technique to work in LayOut. If you are in LayOut and have orbited a viewport, you would need to reset that viewport, and make any changes back in the SketchUp model. Only use the scene menu in LayOut if you want to keep the clipping intact.

The change also will allow you to open existing models that had used this technique, without attempting to fix the clipping.

You can get 2022.0.1 from the downloads page:

6 Likes

This is the second time in recent years that a new version has been replaced with a “fix” that proved unpopular and had to be quickly revised. The other was the use of the Option key with Move to create multiple copies. Looks like in both cases the subsequent fix of the fix did result in an improvement, or at least additional functionality (with more user option). I imagine this is product development “in the field”.

If anyone else get’s this installation error…

Screenshot 2022-02-25 082901

I opened Windows Task Manager and considered terminating the processes – there were two of them.

Instead I Googled what COM Surrogate is and decided to close down all instances of Windows Explorer after which the installation appeared to complete successfully.

( I could have tried clicking Ignore but most of the time when I get something like this clicking Ignore doesn’t work – perhaps it might have in this case…? )

Will there be any release notes Colin?

‘Ignore’ button is probably only set to ignore the button itself, not any related actions😅

I always end ‘com surrogate’ when installing is interrupted, sometimes it shows actually com surrogate, but most times it will give no clue.

I do see that sometimes, but I am doing rapid installs over existing development builds. I click Ignore. Do you think many people will see that?

Thanks for the fix Sketchup/Colin! I’m a happy user again.

3 Likes

Thanks to the SketchUp team (and @colin specifically) for jumping on this so quickly - really appreciate it!

3 Likes

Thank you. I am happy too.

I hate being a party pooper but the fix is not working on Mac. I followed Colin"s instructions to the letter more than once but I do not get a section view at the end of the 4-step process. What I view is the exterior of the building, not a section.

The two-step process works for me: Press down with the Position Camera tool and drag to determine the view direction, release. Switch to Parallel Projection. Using the Standard Views or the Look Around tool “throws you out”.
BTW, it is not a section view but a clipped view. The cuts do not show a section cut edge.

You installed the new release, sure?

Yes, I installed 2022.0.315.

Using the Standard Views works but Pan and Zoom do not. And, I am not expecting to get a section view, for sure. Thanks.

dlw-03

In the first post of this thread you will find a link to the download page of the latest SketchUp version.

1 Like

As mihai.s shows, the latest fix is in version 2022.0.353

Yes! My duh moment! I downloaded it but did not install it. Now it works. THANKS!

1 Like

Haven’t had much clipping problems lately using (SU17) but did find I could use it to my advantage. Mush easier to work on items deep inside a model rather than zooming in or using X-ray but the issue here is how to clip when actually want or need?

One trick you can do with components is to have a copy of the component off on the side somewhere, where there is nothing in the way. You make changes inside that copy of the component, and the deeply buried copy will get the same changes.

colin: Thanks for suggesting this tip. I do use this comp. technique and have just recently on uploaded model for key fob for Sunbeam Tiger which has a tiny, tiny spring hidden inside. Works great but in this case had to really scale it up (10000x) but unfortunately still required some stitching at normal scale. I was just experimenting to see if mods would work while clipped but wouldn’t really need to use much. I see my preferred browser is no longer supported and I can’t make downloads either (Collada not acceptable) so maybe it’s time to cash-out using SketchUp altogether.

I haven’t yet tried the fix in 2022.0.1, but from your description it sounds like it should fix the problem. Avoiding orbiting might be a bit unintuitive, but orbiting isn’t normal when creating elevations with Position Camera anyway, so that shouldn’t be an issue.

I have to applaud the Sketchup team for acknowledging the issue and fixing it so quickly. Thumbs up on that.

I do think, however, that a better long-term solution than backing out the camera could be found to the clipping problem. And I have to disagree somewhat with your assertion that “section planes [are] a better solution.” That is true except when they’re not. If managing a lot of section planes were much easier, and if section planes could address the interior lighting usage case, then I might agree. As they are, section planes are not always better.

Again, thanks to the Sketchup team for taking action on this issue.


Keith

1 Like

Thank you SketchUp,

Downloading version 22.0.354 fixed the getting elevations views without section cuts and using Camera positioning work around and using Parallel projection.