Position camera errors

when I position my camera in parallel projection mode using the positon camera tool to create elevation views in sketchup I have noticed that the placement doesn’t seem particularly precise. If I want to be in front of an object I have found that even if I position the camera in front of an object it doesn’t always put it in the correct position. To remedy this I switch to perspective mode and roll my middle mouse wheel to track the camera forwards or backwards in the scene. Switching back to parallel projection mode my camera is now set at the desired location. When I select this scene view in Layout the scene view does not correspond to the view I have in sketchup. ie it is still positioned behind the object. I am creating elevation views of the interior of a building, does anyone have a solution for this issue? Thanks

Can you share your LayOut file so we can see what you’ve got set up?

Keep in mind if you do something in LayOut that modifies the viewport’s Camera properties, changes you make to the camera properties in SketchUp will not show up in LO unless you reset the viewport.

Is there a reason you aren’t using the standard views for your scenes in SketchUp?

Hi Dave, Do you need my Sketchup file and my layout file? The reason I am not using standard views is that I need to position the camera in specific location in each room eg. between a toilet and a cupboard so that I don’t see the toilet in my view. regardless of how precisely I position my camera from my plan view the view plane seems to shift or clipping occurs.

The LayOut file will contain the SketchUp file.

Maybe you could assign a tag to the toilet component and turn off the visibility of the tag for the scene.

Sometimes the object is a wall so that wouldn’t be practical. I’ve can’t upload the file with your upload link because it’s too large. Here’s a dropbox link Dropbox - UBC PowderRoom01 purged.layout - Simplify your life

If you look at page 4 - (bath elev C) , showing scene - Powder elev C. You can see that a wall is obscuring my view. Here is a screen grab of the view in sketchup.

When I opened the SketchUp file it was also showing the wall obscuring the view because the wall is actually between the camera and the stuff you want to see. If you orbit very slightly in the SketchUp file you’ll see the wall. Give the wall a tag and turn if off. I did that here.

By the way, it wouldn’t hurt to purge unused stuff from your model once in awhile.

Screenshot - 10_5_2021 , 9_00_48 PM

With the Camera set to Parallel Projection there isn’t really a distance sort of property like there is in Perspective. You need to get intervening objects out of the way to prevent them from showing in the scene. In a case like yours things can be deceiving because it sort of looks like you have the camera position inside the powder room but it isn’t really.

I’ll purge now, and try tagging the wall and hiding it but I just checked by orbiting and the view line cuts in front of the wall not behind it. As you can see the project is quite large and I need to generate lots of elevational views. It’s really not practical to tag individual walls

See the addition at the end of my previous post. It isn’t appropriate to apply Perspective camera thinking to Parallel Projection. It just doesn’t work the same way. I think it’s more practical to either tag wall groups–that one chunk of wall is a group on its own–or use section cuts.

I would love to use section cuts because I’m having to manually trace out the outline of each room as a clipping mask in layout for each interior elevation and I have 4 to generate per room and there are many rooms soI don’t think section cuts would be feasible? It would be handy if I could generate a reference point and align my camera position to it

when I position camera in top view does the distance between where I position it and the length of the direction I click again in make any difference to the view plane? It really doesn’t seem to be very accurate. Your point about getting intervening objects out of the way shouldn’t be necessary if the position tool was accurate. Has anyone else contacted you with similar issues?

Do you know that you can click and drag the position camera tool to aim it?

yes but it is inaccurate in terms of how much in front or behind the position it clips.

It isn’t for Persective views. You seem to be ignoring what I told you about Parallel Projection, thoubh.

I’ve seen a few cases of this in the past. Most people Use section cuts and tag visibility to handle this sort of stuff the way it was meant to be handled.

Thanks for all your help and you were entirely right that my camera position was in fact behind the wall. Unfortunately generating section cuts for the number of elevations I am working with would be really difficult to manage (unless you have a method that doesn’t result in them obscuring everything in the viewport?). Similarly showing and hiding objects through tagging wouldn’t be feasible to manage due to the complexity of my scene. You might be interested to know that I did some research into clipping planes and found a free extension by M Moser called Camera Clipping Fix which does exactly what it says. By setting the near clipping value I can easily get the desired result. I have noticed that setting the near clipping plane seems to set it universally for the project. As I am creating elevations of each wall for numerous rooms in a large house I think I will need to construct a guideline template shape to specify exact locations to use the position camera tool in plan for elevations A-B-C-D for each room so that clipping works for them all
Cheers

Actually there still seems to be problems here

1 Like