Why does my SketchUp model have a "ghosting" effect when I rotate it?


#1


My model looks fine from a distance, but as soon as I zoom in about this far, the structure becomes see-through (image attached). When I add shadows to my model, the shadows are also completely messed up. Does anyone else have this problem?


#2

Hard to say from just a screen shot but it looks like you have some Z-fighting going on. If you share the SKP file we could take a look at it and tell you for sure.


#3

Here is the lovely file!! Thanks for your help thus far. I looked up Z-Fighting…very interesting read.

Big file use link below

https://umbc.box.com/s/2f4xwli4dq4sub2w6debywwqrqo86dq0


#4

Well, not Z-fighting but your model is a long way from the origin and that sort of thing is known to create weird graphics issues. Move it to the origin and I expect you’ll see better performance. As it is it’s nearly 264 miles to the left and 110 miles behind the origin.

Here’s what I see with the model at the origin.


#5

there was also a stray edge some 400 miles away from origin and a (hidden) component .

If you select all you can see, type M for move and then select a corner to click on, drag a little and let go of the mouse. type [ (bracket) , 0,0,0 followed by enter (the closing bracket is inserted automatically and the separator is determined by the local keyboard settings))
This should move the lot to the origin.
You can then type Ctrl A to select everything and while holding Shift, select the lot again. This will select the stray edge so you can delete it.
The component can be found in the component panel or outliner.
Right-click on the component and select instances or click in the outliner to select.