Bizarre behavior of shadows


#1

If shadows are turned on and when I’m rotating the model at some point something intersects model, fist cutting parts off and finally hiding the model entirely. Basically I can only look at my model with shadows on from one side. Same behaviour occurs also from some angles if I zoom in. what is wrong?


#2

In SketchUp Help menu there is a Knowlege Center. You’ll find your dispay issues under “Clipping plane” which brings you to “Clipping & missing faces”.(link below)
See: http://help.sketchup.com/en/search/sketchup/clipping%20plane

There are some tips to restore and/or avoid clipping plane issues mentioned in the article.


#3

Tried to post this earlier but site was in “Read Only Mode” what ever that was. Wo3Dan`s info is what I was trying to get across.


Model disappears with shadows turned on
#4

It has certainly nothing to do with causes as described in Clipping & missing faces issues video. Problem seems to be how Sketchup deals with Geolocation. If I clear the location everything works fine but if I use maps to find my exact location it seems to put something additional to my model.


#5

Might you share a model that exhibits the problem?


#6

Without seeing the problem (a screenshot would be mighty helpful, here), my first inclination is that maybe this is a “Shadows on Ground” issue. In terrain situations, you pretty much always have to uncheck that option. Here are some screenshots:

A common problem, which cuts poor Steve in half:

And here is the solution to that problem:

I hope that helps. If it doesn’t, then please, please upload a screenshot to help us help you.


#7

Although, after re-reading your reply, this doesn’t seem like a ground-shadows issue so much a file size issue. What is your file size? Have you tried Purging the file, saving, closing it, and then re-opening it? Terrain models can get pretty huge very quickly.
Also, have you tried changing the field of view?
Essentially, though, unless you upload screenshots for us, we’re stabbing in the dark. Please, save us time guessing and upload some visuals of angles where it doesn’t show the problem, and others where it does.


#8

Try the shadow strings extension - it addresses an old bug.


#9

For now I just deleted geolocation and the model is behaving normally.
here pictures WITH geolocation.


#10

and second pix


#11

nr 3 (I can only use 1 pix per post :frowning:


#12

that’s not ‘Shadows’ it’s ‘clipping’, a common openGL issue…
there are ways to minimise it…


#13

Here’s a help page about the OpenGL clipping