Everything in my foreground disappears

It happens when I use the Shift + Scroll Wheel to orbit or translate the camera. I would be moving the camera with a drawing tool out when everything instantly becomes hidden or disappears from view (including the axis). But I am still able to draw lines just not see them.

Sounds like near clipping plane issue.

You may need to adjust your field of view.

Switch to ZoomTool, and you’ll see the current Fov setting in the Measurements (VCB) box. Change it to a more narrow FoV. (The default is 30 deg.)

Here’s what I see when it happens. And there is supposed to be a model here.

I tried to lower the FoV but it was to no avail.

Clipping & Missing Faces — SketchUp Help

You may need to check if Fog is ON ?

Window > Fog

Uncheck it or adjust the distance.

Heh. I am sorry if I’m being difficult or anything like that.
The clipping and fog weren’t the problem, everything is default. I don’t ever use the fog, and I know it is not the view clipping because I hit zoom extents. It’s more like everything is hidden (but I don’t actually hit “Hide”).

Mind sharing the model file so we can work with it?

Zumwalt Class Destroyer.skp (297.8 KB)

It happened to two of my models. Here’s one of them.

I find nothing wrong with the model.

Me neither, even if I turn on parallel projection.

it’s even fine on a mac…

I’m guessing it’s probably my computer then. Well that is just fantastic.

Thanks for the help.
I know this is off the topic of the thread but is there a way to add images or pictures to models in SketchUp? If so, could you tell me how or direct me to where I could find out how.

[quote=“generalrialki, post:13, topic:11313, full:true”]
Thanks for the help.I know this is off the topic of the thread but is there a way to add images or pictures to models in SketchUp? If so, could you tell me how or direct me to where I could find out how.
[/quote] Import 2d…
Check the option for ‘As Image’…

To add a little to that, once you have done the import and as image, you then click once to place it, move the mouse and click again to set its size. Or just double click to place it at its original size.

An alternative is to import as a texture. The only difference is that you then place the image onto an existing surface.

No buts about it.
It’s best to start a new topic rather than clutter this one.

And there is also Watermark images in a style.
You might check your style, if there is a watermark on.

On your screenshot, I see a very faint box that looks like a tooltip or a mouse popup menu, that says (I think,) “Window Snip”.

Do you have some 3rd party screen grabber utility running ?
If so, try disabling it to see if it is the culprit.

Do you have any render programs running ?
Try disabling them also. Threre may be a Z-order issue with an overlying window object on your screen.

Save the model, close and restart SketchUp
Does the issue still occur ?

Close SketchUp and reboot computer. Restart SketchUp and try again.
This is to totally refresh memory in case an error caused memory corruption.
Does the issue still occur ?

1 Like

Try this test in SketchUp:
Click … Window > Preferences > OpenGL > deselect Use Hardware Acceleration
Shutdown SketchUp and then restart SketchUp for the new setting to take effect.

If that helps, then the likely problem is a deficiency in OpenGL support from your graphics system.
Sometimes OpenGL problems stem from an outdated graphics driver.
Updating the graphics driver may fix the problem.

How can I update my computer’s graphics driver? — SketchUp Help

I unchecked the Use Hardware Acceleration and restarted SketchUp. I opened one of my models, orbited the camera around a bit, and then it crashed, completely.

Try the following:

  1. ZoomExtents
  2. Select tool, select from top right to lower left of the screen. This should catch everything in the drawing.
  3. Control or Command C (copy)
  4. Open a new SketchUp file
  5. In the new file Control or Command V (paste)

All your information should be in the new file.