Model disappears and/or view zooms out massively


#1

Hi,

The issue I have is when I move close to the model (sometimes) it completely disappears. Other times it seems to zoom the view a long way away from the object. This isn’t a clipping plane issue as sometimes I can get closer than others. Its just seems very random and it is making the use of SketchUp impossible.

I have uploaded the model here. https://www.dropbox.com/s/vhp1i4bbc89rmfg/DP3.skp?dl=0

It’s driving me crazy!

Any ideas? Is this a SketchUp 2018 issue or a model issue?


#2

That usually happens when one or more of the groups/components has its axes far away from the geometry. I’ll try to download your file and have a look :slight_smile:


#3

It looks to me as if it has to do with your setup. Switch the camera to Perspective and set the focal length to something reasonable like 75mm. In general, you’ll find it much easier to work in SketchUp with the camera set to Perspective.

The axes are not located terribly far from the geometry.


#4

Isn’t this also something that happens when you have the cursor hovering over open space when you try to zoom? The cursor needs to hover over something that has been drawn to make zooming easy.


#5

You say it is not a (static) rendering issue like clipping. Does it happen when you intentionally interact with the model, or does it happen on its own? Can you describe how you interact with the model (selected tools, mouse clicks, movements)?


#6

All I am doing is mouse wheel zooming in and out of the model and randomly it will disappear.

When it disappears I have to hit zoom extents to get it back again.

I set the FOV to 75 degrees (from 45) but no improvement.

Here’s a video of what happens. All I am doing in using normal mouse movements to move around.

Cheers,
John


#7

Hmm, that video link didn’t work well…

Try this:

add this bit (https://www) to the main link below and paste it into a browser…

.dropbox.com/s/er5hooobirjoxfe/Untitled%20-%20SketchUp%20Pro%202018%2029_06_2018%2014_24_21.mp4?dl=0


#8

As was already mentioned, if the cursor is not on the model, zooming can be an issue.

I didn’t tell you to set the FOV to 75°. I wrote 75mm.


#9

Not sure how I set the focal length…?

I have used SketchUp for several years and have never seen the behaviour i am seeing - and through that time I have not taken care to check whether the mouse is on an object before I scroll.

Did you check the video? I was not doing anything odd, but the behaviour is very weird.


#10

I can’t see your video but I see strange behaviour when viewing your SketchUp file. The model was there, then disappeared without me zooming at all, just panning a small amount and it vanished.

You have some very large geometry which is causing the camera to behave strangely. For example this component:
3DGeom~2258_Defintion#2
Has geometry that extends from -26km to 26km below and above the xy (red-green) plane.

Another example, 3DGeom~2292_Defintion#2:
Coords of the points (x,y,z) of the component 3DGeom~2292_Defintion#2.
(~ 2001637.3mm, ~ 5085639.1mm, ~ -26602840.8mm)
(~ 1992285.0mm, ~ 5085843.2mm, ~ -26602840.8mm)
(~ 1992285.0mm, ~ 5085843.2mm, ~ -26602840.8mm)
(~ 1992170.1mm, ~ 5075296.3mm, ~ -26628240.8mm)
(~ 1992170.1mm, ~ 5075296.3mm, ~ -26628240.8mm)
(~ 2001637.3mm, ~ 5085639.1mm, ~ -26602840.8mm)
(~ 1992170.1mm, ~ 5075296.3mm, ~ -26628240.8mm)
(~ 2001637.3mm, ~ 5075296.3mm, ~ -26628240.8mm)
(~ 2001637.3mm, ~ 5075296.3mm, ~ -26628240.8mm)
(~ 2001637.3mm, ~ 5085639.1mm, ~ -26602840.8mm)
The z-coords (blue) are 26km below the origin.


#11

Interesting - thanks for taking a look.

Do you know how I would fix that? I pulled some models in from Step and Iges files.


#12

spacebug,
The three types of connectors you used were created in a very strange way. The subcomponents (the ones named 3DGeom~xxxx) were all sized differently and about 100,000 times too large, to compensate the containing ‘Component Instance’ had a transformation that scaled them back into normal sizes.

I’ve repaired the components. You can download them here:

light weight version (- with all of the subcomponents exploded)

or is that doesn’t suit you can try these

And the Ruby code to accomplish this task if you need to do the same thing in the future
resize explode v3.rb (755 Bytes)

Best


#13

I don’t think this would be very easy to fix manually. I did it with Ruby.

There were 6607 components with geometry more than 1km from the origin. One of these I looked at had zero length edges, I only looked at one, there could be thousands.

This text file has a list of all the problem components:

Components outside 1km.txt (238.6 KB)

Here’s my ‘fixed’ version with 6k components removed. It’s only 13MB now:

I have a feeling that you’re losing something by deleting all these components. Were they models of tiny surface mount components? Maybe they got corrupted in the export/import process somehow.

sWilliams just posted while I was pasting this here, I haven’t looked at that yet.


#14

Hey McGordon, FWIW here’s the Ruby code for just ‘resetting’ the component transformations by exploding each component instance into a same-named group.

resize v2.rb (835 Bytes)

I’ve had no luck doing this with only the native tools. But surely someone will post a simple solution.


#15

Thanks, I hadn’t noticed that there were translations reducing the definitions back down to ‘normal’ size. That explains why the bounding boxes didn’t look huge.

I’m slowly building an extension to fix problems in models, but I keep finding new weird problems, like the ones in this file. I wasn’t looking for extra large/small translations that sWilliams spotted, so I missed those.

In “TempSimLab_2018-06-26-14-20-49 v3.skp” (the yellow connector) still contains the groups I deleted, but they seem to be sensible distances from the origin now. The first one on my list was 3DGeom~315. This group contains no faces and just one short edge, around 1mm long.
(~ 56.9mm, ~ 18.5mm, ~ 231.3mm)
(57.9mm, ~ 18.5mm, ~ 231.3mm)
y and z coords are identical and the x-coords differ by 0.04098978568249789" (1.0411405563354463 mm). I tried to look at the original version of that component and it seemed to have 5 edges, but this file is quite confusing with lots of similar named components, so maybe I got the wrong one.

Using Cleanup3 on sWilliam’s file to remove stray edges gives:
14572 stray edges erased
Which removes all the groups matching /3DGeom/. I don’t think there’s anything useful in these components anyway, but maybe spacebug can tell us.


#16

Thanks for looking in to this. I’ll log on later and take a look.

I really appreciate all the assistance!

Out of interest. How did you interrogate the model to find the issues? I can’t seem to find any means to do that.


#17

Hi sWilliams and McGordon,

Thanks again for your help in getting to grips with the issues I had. I still have other components that I suspect have the same issue. I’d rather try and fix those myself but I am in need of some pointers.

I have tried the Cleanup3 extension but this doesn’t seem to make a huge difference on it’s own. I have tried using this Ruby code (never used it before) without much luck. I assume it’s use should be - paste the ruby code into the console - select the model - hit enter…? When I do that Sketchup just hangs. I may not have waited long enough i guess?

How are you interrogating the sub components? I can’t see any way that I can see these sub components that you are referring to? Is there an extension I need for that?

For background - the components were pulled from the manufacturers 3D library and were either stp files or iges files. I used the SimLab stp and iges importer extensions to get them into Sketchup.


#18

OK, just tried again with the Resize v2.rb code and was a bit more patient. Sketchup eventually came back to life after ‘hanging’ for around 3 mins.

What I still don’t know how to check are the statistics on what was cleaned up or what was a problem in the first place.


#19

An example of the problem is this component which internally has edges that are very long but are scaled down by a factor of 1/155364 to end up with a real world length of circa 0.1 inches.


#20

How do you get to see that data?