Shadows too large?


#1

hola hola :smile:


I am building this model and I have been working with the shadows “off” since the beginning…when I finally turned them “on” this image is what I see…I think the super-large shadows to the left of the image are from the building??? how can they be so gigantic? (see time of the day and year) any ideas would be greatly appreciated, cheers, a.


#2

What is the latitude you have set under Location in Model Info?

And, out of curiosity, if you right click on the origin, is Reset shown in black or gray? and if it is black, what happens when you click on Reset?


#3

They (shadows) would be much larger if your model would be located closer to north pole.

In other words, is your model geo-located at the correct position? It doesn’t seem to be, looking at the icon down left on your status bar.

Import the right location (and orientation for true north) by using ‘Add Location’ in SketchUp’s ‘Google’ toolbar (first icon on that toolbar). You may have to rotate your model accordingly. Or better yet, change true north with a plugin if you don’t really need the Google snapshot and imagery later. That way you can keep the drawing axes as the systems axes.


#4

I have right-clicked on the origin and reset scale and reset skew are both showing in grey…no idea what this is though…


#5

this is getting better… :grin: I have geo-located the model and now I get this:


it’s like is really foggy and the extract of g.earth is barely visible!! surely sketchup does not know it is foggy (bad joke)


#6

Right clicking on the model origin should not show options “Reset scale” or “Reset skew”. The only reset menu item would be “Reset”. If you saw something else, you weren’t right clicking on the model origin. It sounds like you right clicked on a texture.

Your new screen shot makes it look like you have Fog enabled. Do you?

I asked before but you didn’t answer–what is the latitude?


#7

about 50.7 degrees
by origin you mean where the 3 axes join?


#8

Yes. Where the 3 axes cross. If there’s geometry overlying the origin it can be difficult to click on so it’s easiest if you hide that geometry.


#9

Or right click on a visible red, green or blue line without any geometry around.


#10

done it; reset shows in grey


#11

Gigantic compared to what?

There are four parameters you must set to display shadows that accurately portray the real world.

• Geographic Orientation — Relationship of True North to the model.
• Geographic Location — Latitude and Longitude
• Time — Year, Month, Day, Hour and Minute
• UTC Offset — The difference between local time and the Coordinated Universal Time standard.

Check your settings in the model against what they should be in the real world.
Share the file if you have difficulty sorting things out.


#12

thanks everyone, problem solved…
mmmm :grin: can I ask if you know any good tutorial about modelling ground? I am going mad at the moment every time I want to make a little mound or grassed slopes etc, big thanks, alex


#13

What was the solution to the problem. It might be helpful to the next user who has a similar issue.


#14

i think it was as simple as that my model was not located anywhere, once i added a location to it the shadows look fine, thank you too, a.
…any tips on the ground modelling…?

“mmmm :grin: can I ask if you know any good tutorial about modelling ground? I am going mad at the moment every time I want to make a little mound or grassed slopes etc, big thanks, alex”


#15

So it was the location as I suggested in my first post? Good to know.


#16

Every model has a Location, even when the model is not Geo-Located.

The default location in SketchUp 2015 is:
USA
Boulder (CO)
40.018309N
105.242139W

SketchUp automatically sets the UTC Offset for the default location at UTC-7, which is
the correct UTC Offset for Mountain Standard Time observed in Boulder, Colorado, USA.
Boulder, CO is currently observing Mountain Daylight Time, which is UTC-6


#17

thanks for the explanation, for some reason my model was on UTC-0 when the shadows were so large.


#18

This is where it leads to:


I understand that is where the developers sit (or used to).
Anssi


#19

To geo=locate the simply default located modeling space (otherwise ‘Shadow Settings’ would be useless from the start) to get it into Google Earth you can just change (CO) 4 0… to 4 1… > ok > back to 4 0… ok.
This triggers the geo-location icon to On

A useful site to find lat/long values and gps coordinates is www.latlong.net, among others.


#20

In Google Maps, right-clicking on the map and selecting “What’s Here” (or whatever it is in English, mine displays in Finnish) will also list the coordinates. Useful if you want to manually locate your model without bringing in the often not very helpful GE terrain.

Anssi