Model disappears with shadows turned on


I’m working on a model of a house and I need to work on solar gain, so I’m keen to use the shadows feature of Sketchup. When I turn on the shadows, however, my model disappears unless I’m looking directly down on it from above or am very far zoomed out.

I have looked over all the information about clipping and I’m confident that my model hasn’t got any of these problems - I have no stray geometry, my scale is sensible, and one corner of my building is right on the origin point. I’ve tried with shadows ‘On Ground’ both on and off, and it makes no difference. I’ve also tried to removing my geolocation, and that makes no difference either. As soon as I turn shadows off, however, the issue goes away, which makes me reasonably confident that this isn’t a generic clipping issue.

Experimenting with different times and angles, it would appear that the model gets clipped when the sun is too low relative to the angle of the camera. If the camera is directly over the model, you can change the time/date to any value and the model never disappears. As you move the camera lower, it becomes more and more sensitive to the angle of the sun - later in the year or at the ends of the day the model starts to disappear. With the camera horizontal, the model disappears even at noon in the middle of June.

[EDIT] It turns out that rotation is another relevant variable. The closer to directly opposite the sun you are, the more the model is displayed. When the camera is between the sun and the model, the problem is at its worst. [/EDIT]

I’m using version 16.1.1451, and I’ve uploaded my model in case anyone can shed any light on what’s happening here.Finca.skp (1.6 MB)



What you’re seeing is referred to as clipping. You can see it toward the end of the animation, above. It’s not specifically due to turning on shadows. It has to do with the fact that you have other entities located at a great distance from the origin. In this case it’s a little sliver of terrain positioned over 10,000 meters up the blue axis.

Delete that and your clipping problem will go away.

1 Like

Wow, ok, I thought I’d followed all the steps to find rogue shapes like that. How did you find that piece? I’ve tried selecting all and then deselected the visible model and deleting, but that didn’t work. In fact, I’m struggling to even find that sliver of terrain even now you’ve told me about it!

As an aside, I didn’t put that terrain there. I think that must have been put there by the geolocation process - and I can see how this would trip a lot of people up. I’ve seen other threads on here mentioning similar issues - is this perhaps a bug/usability issue with the geolocation system?

Ok, I finally found it using the outliner. It’s worth noting that the standard steps for selecting and deleting rogue components didn’t work for this, because it was locked, and there was no warning that there was a problem…

But anyway, many thanks for the detailed and patient explanation of how to fix the problem!

I used Zoom Extents to figure out that you had something a long way from the origin. I knew the model is close to the origin so I dragged a selection box around the upper part of the drawing window to try to snare the offending bit. Usually I would hit Delete and try Zoom Extents again but that wouldn’t work in this case because the terrain is locked. I looked closely and saw a tiny red dot which I then zoomed in on. It helps to have a keyboard shortcut for Zoom Selection.

When I started hunting for the problem, I assumed it would be some little edge segment which is what we typically see. If I’d know it was a component, I’d have worked through Outliner. Even without seeing the terrain component, you could right click on it in Outliner, unlock it, right click on it again and choose Erase.

I don’t know how the terrain got up there. I’ve never seen terrain get put so far from the origin. The origin is not at 0,0,0 as it ought to be but it’s not located to create a problem for positioning the terrain.

BTW, to delete the terrain, you’ll need to unlock it first.

Who “geolocated” the model or what model or ill created template did you start from? I’ve never seen ‘Geolocate’ make such a mistake but it would be easy to manipulate a model this way and share it in 3D warehouse.

I created the entire model from scratch. I then geolocated it by putting in the co-ordinates directly. It created the background map photo as I would expect but then I turned on shadows and started to notice the clipping. The only reason I mention it is because it sounds remarkably similar to the issues mentioned here: Bizarre behavior of shadows - #3 by mrwmrutski

I’m as sure as I can reasonably be that I didn’t do anything to put that extra slice of google imagery up there - I didn’t manipulate the background directly at all. My impression is that there may be a particular set of circumstances under which adding a location does something odd; it’s quite possible that my model was not configured in an optimal fashion - I’m not an especially experienced user of the tool - but I did very little between adding the location for the first time and the problem showing up, so I’m not really sure how I could have done it inadvertently…

1 Like

as you can’t move locked groups, it’s the building that was moved 10km away from the terrain…

if the terrain was ever in the correct relationship to the building, then it’s move happened after the import…

I have had similar happen when a selection is ‘stuck’ to ‘Move Tool’, and I’ve been interrupted…

on return to the model I’ve ‘clicked’ on the window randomly, to wake SU up…

the ‘stuck’ selection is suddenly dropped near Mars…


Hmm. The interesting thing in this case is that the problem terrain was a funny little sliver that was additional to the main background image - and as far as I am aware, I didn’t geolocate the model twice. In the model that I uploaded, I had deleted the proper terrain image, because I was worried that this might have been causing the problem. And furthermore, I never noticed the building moving away from the origin, which I surely would have done if I’d moved it by accident.