Why do all the extra SU window vanish on my Mac when I do this?

At home I’m working with SU on my macbook pro along with a external monitor.
I’m running SU on the external monitor. When I go back to the laptop monitor and click on the laptop screen all the SU windows except the main one vanish. As shown in the gif.

To get all the SU windows to show up again I have to go back to the external monitor with my mouse and click.

Is this just the way it is with mac and dual monitors or is there a setting I have not found yet that I can change?



you need to Assign SketchUp to a ‘Desktop’ by Right clicking on it’s Icon in the Dock…

have a search with some off those words and there’s a gif or two and further advice from Steve…


Hmm, I don’t seem to see any desktop option after right clicking on icon in dock.

Well Im getting something figured out. I had to add another desktop. Now I have the option after I right click on the icon. Still seem no matter if I assign it to, “Desktop on Display 1” or Desktop on Display 2" the same thing happens.

I’m not running dual monitors, but the jumping occurs in other situations as well…

maybe if your bouncing back and forth you need it assigned to ‘Any’ or @slbaumgartner may have some additional info…


Yeah, I tried the other options too, All Desktops or None.

I also tried this

I found that unchecking

Preferences->Mission Control->Automatically rearrange spaces based on most recent use

also helped. I think SketchUp gets confused when the spaces are renumbered based on use!

as suggested in this topic.

Nothing I have tried so far has helped.

This is normal behaviour not only with multiple screens. When SketchUp is’t the active applicaties (you can see which programs menu is on top of the screen) the child windows aren’t displayed. I also find this very enoying.

Annoying or not, that is completely standard Mac OS X behavior and is not SketchUp’s fault. Every other app that has auxiliary windows behaves the same!

Thanks for the info. Now that I know it standard I can stop looking for a way to change it. :slight_smile: