Why aren't my components showing up?

I am using the free version of Sketchup for a school assignment. I have been trying to add models from the 3D warehouse into my project. I click on the item I’d like to add, it tells me it downloads, but then nothing happens. I’ve tried zooming out very far and still I can’t see anything. How can I fix this?

Try zooming in, your model is probably huge and the components are the right size.

1 Like

Hi, thanks for your response. My model is pretty big – it’s an intersection of a street in an urban setting. I’ve tried zooming in to all spots I can, and I still can’t see the components.

@ibergelt, save your current model and start a new one. Try downloading one of these components into the new model to see what happens.

Thanks for your suggestion. I tried this and I was able to successfully upload a component into a new, blank model. So, it seems as though the components are hiding behind my current model? Any tips on how to recover what’s been hidden?

Are there active section planes in your previously saved model?
Or does it have anything to do with turned off taggs?

Do you know where I can check that? Sorry – I’m a newbie to this program!

The “house+section plane” produces section planes. (above the “shoes” icon on the left.
If the section plane is visible, you can double click on it to togle it active/inactive.

On the right you have the “display” icon (glasses) that lets you see what can be controled further, (also visibility of section planes and/or cuts)

Thank you so much for such a detailed message.

In the display icon, what should I have checked or unchecked?
Should section planes be active or inactive?

If you are still new to this program, I think you should not have any section planes at all. If you see any, delete them.

And good practice for loading models from the 3D Warehouse is to download and open each on in a new SU window. Many of them are badly made, grossly over detailed, and quite often use layers wrongly. Sometimes they are wrongly placed, far from the origin. Some are to no meaningful scale - not life size, far too big or far too small.

Look to see how big each 3D Warehouse model file is - both in KB and in number of edges and faces (Model info/Statistics). ‘Entourage’ - plants, people, furniture, cars etc. - don’t need excessive detail, and a single copy of a piece of furniture is almost certainly ‘too big’ for use in this way if over a few hundred KB, or a few ten thousands of edges, in my opinion.

‘Heavier’ models included in you house model may make it sluggish in use, as SU struggles to display all that geometry.

If you want more specific help, upload your model here.

But first you have to download it to your computer. Click the folder icon top left in the SU for web interface

and click Download to do that. Then drag and drop it into a post you are editing on the forum. Or use the eighth icon above image to start an upload, and pick the file.

If you are a newbie, start here at The learning Center. Lots of great info on the basics!

Experiment with a simple cube and a section plane and the various settings of the icons:

  • display section plane
  • display section cut
  • section active / inactive

There may not be a need for you to have a section plane in your model.
I just questioned the existence of one in your model. But not likely since you say you are new to SketchUp and don’t seem to know how they work. You could have introduced one in your model by importing a new component. Who knows.
Measure the visible component in your new model and compare this dimension with geometry in your previously saved model. @Box may very well be on the right track with mismatching sizes.

Also, is your model close to the systems origin? when you right click on one of the axes, is ‘Reset’ available or greyed out?

Reset is grayed out! Could that be my issue?

If Reset is greyed out, that means your axes haven’t been changed and don’t need reset.

If you’d shared your model here, someone would have found the issue two days ago.

Sorry about that – here is my model! It looks terrible, I know. I am a newbie after all.Designing the city assignment 3 #2.skp (5.7 MB)

Your buildings are quite tall. This one is 5,876km high

Your trees will look quite small compared to that.

You’re right, I didn’t realize that the building heights would affect this so much. I really appreciate you telling me this. How tall do you recommend a skyscraper to be? I will adjust my other buildings based on this.

I’m trying not to be sarcastic here, but 667 times the height of everest is a bit much.

As a rough guess, I scaled the whole drawing down so the storey height (window-to-window) of one of the buildings was 3m.

This would scale the trees down too, so you’d have to find all those components and drag them out of the components browser again. I placed one tree back into the drawing and it looks more like the right size now.

Designing the city assignment_gm.skp (5.7 MB)

No I think that’s hilarious - to make a building over a million stories high is outrageous. Sorry for the dumb questions, but how do I scale my drawing? Due to the coronavirus and home instruction we had to figure out this program on our own, so I have absolutely no idea what I’m doing (hence the 1,000,000+ story building).

Thank you so much for your advice.

I scaled it for you and uploaded it.

To scale the whole drawing yourself, use the tape measure tool. Measure a size as normal, then type the size you want it to be. SketchUp will ask if you want to scale the whole drawing and if you confirm it will do it.

If I measure from the bottom of one window the one on the next floor (if your building had floors between these windows) and it says 1018444’ 6 7/16" (1 million feet). If I type 10’ and press return a box pops up “Do you want to resize the model?” click yes. That size will now be 10 feet.
Storey height