Issues importing components

Hi there,
I am new to sketchup and using for my studies. I have watched many tutorials and I think I can deduce that there is something wrong with my programme. I can download my furniture into components from 3D warehouse and they are visible in my components section but for the life of me I can’t get them into my plan view… Can anyone help? I have tried dragging and dropping/going to file>3D warehouse>(then I don’t have an import option just export).
Many thanks in advance!

Check the scale of your model. It is possible that your model is so large that the components are so small you can’t see them.

Thank you - how do check the scale?

Use the Dimension tool to measure something you’ve drawn.

Then no, it is to scale… so not that issue

How about sharing the .skp file with us so we can see and not guess at why you aren’t seeing the components?

Are you working in 2d, looking down on the plan? Perhaps you are putting them Under the plan.

Thanks Box, yes i’m working in 2d. How do I ‘bring to the front’ if that is the issue? even when I move the arrow aside of the plan I don’t see any shapes etc…

Sketchup is a 3d environment, use the orbit tool to move around and look.
But as @DaveR has already asked, attach the file so we don’t have to guess.

LFK.skp (4.8 MB)

Thank you - here you are

Thanks - i’ve attached it above - appreciate your help

That is 2104 m, over 2 kilometers.


1 Like

As Box points out, it is that issue. The floor plan is drawn at over 9 Km wide. You’ve got units set to Meters but modeling as if they are set to millimeters.

OH my WORD! I set it to mms… you guys are absolute legends. Do I need to start from scratch then? How can I make sure it is MMs?

You can change the units to mm in Model Info and you could scale the floor plan down. Before scaling it down, get the Select tool and triple click on the floor plan. Make it a group or component. Then open the group/component for editing and use the Tape Measure tool to measure some known distance such as the 9600 meter width. Click at both corners. Then type 9600mm and hit Enter. You’ll be asked if you want to resize the active group/component. Do it.

Frankly I would just delete all of the dimensions before doing this. You could resize the scale bar as for the floor plan or maybe just redraw it.


Thank you - really. I will work through your instructions - this is all new to me and clearly not second nature!

Good luck with it. It will come with practice.

I would also lean toward erasing all of the furniture and appliance components from the model space because none of them will be in the right location. After you make a group of the floor plan, hit Ctrl+A to select everything in the model space. Then get the Select tool (Space bar) and hold Shift while clicking on the floor plan group to deselect it. Hit Delete. After that resize the floor plan as above and bring in your components from the In Model components panel and put them where they belong.

I think its probably better for me to start from scratch - i will most likely mess it up. Could I ask you one more question - where do I go to make sure that it is set to mms and not gigantic kms!? Much appreciated

Starting from scratch wouldn’t be a bad idea. If you create a new file you should be offered the choice of units.
Screenshot - 7_28_2020 , 7_47_36 AM

Otherwise find Model Info on the right and choose the units. I would also turn off Length Snapping.