Where did transparent background go?


#1

Hi everyone,

anyone noticed in 2017 Layout transparent background is missing? I mean when I export top view I have white background behind my model. In 2016 it used to be transparent. Anyone know how to fix it?


#2

Did you look in the SketchUp Model inspector window under the Styles tab? It’s in the same place it’s always been.


#3

Hi Dave,
thanks for quick reply!
It doesn’t do anything for a background it still stays white, not transparent. See screenshot. Do you get transparent background?


#4

I do get a transparent background. Try rendering in Hybrid instead of Raster.


#5

Hybrid has white background also. Only vector seems to fix that, but it is not an option for me. Maybe it got something to do with sketchup style? Can you send .skp file the one which makes transparent background. I will try to open it on my machine.


#6

Upload the LayOut file. If you don’t want to make it public, click on my name and then “Message” and send it privately.


#7

Here it is.
I also tried to use default sketchup templates both for sketchup and layout and still get white background

TEST Layout.layout (1.9 MB)
TEST Sketchup.skp (740.8 KB)


#8

Hmmm… I just selected the scene in the Scenes list and the background went transparent. I wonder why it doesn’t do that on your Mac. Graphics card issue?


#9

Then it must be something to do with either mac version or graphics card.
here is my mac details. I don’t know much about graphic cards…


#10

on El Capitan I see some issues with raster, but changing the styles shows the transparency…

john


#11

Then it must be graphics card… what is yours John?


#12

mine GC is a very old amd in a mid 2007 iMac…

There are other threads about Sierra having some GC issues and one for submitting your card details to help resolve the problem…

It seems to be specific cards rather then Sierra itself…

john


#13

I have the same problem and have been told that it’s a bug with people running an AMD Radeon R9 graphics card. Cant wait for them to fix the bug because it really lengthens my work time when trying to export with transparent background. I have to erase each background in photoshop first before I can continue…


#14

Lets hope sketchup team fix this soon. It’s not the only problem I’ve found. Here is what I get when exporting to layout. This problem is not consistent. Sometimes it’s there sometimes it’s not…



#15

This one has already been discussed here and traced to an issue with the drivers for some graphics card drivers. The fix for this will have to come through Apple.

See: Black areas showing up in 2017 Layout viewport


#16

I know this thread goes way back but just coming across this as I’m new with the sketchup workflow and this seems to ‘fix’ the issue - shaded with textures is the style that works - the others still produce a white background. Thanks for raising this option as a workaround!