Bad graphics card or bad SketchUp?

Hi, for the last month when I switch to a nice style to export visuals, my components become invisible, so I can see lines behind them. My SketchUp seller help person advised it was related to my graphics card but I have a pretty decent graphics card. I am using a pretty new mac macbook pro, Radeon Pro 560X 4 GB Intel UHD Graphics 630 1536 MB.

Any advice on this would be appreciated. Whenever I contact my SU re-seller he seems to hate macs and tells me most people use SU on a PC as they are more powerful.

Many thanks

Apologies, I havent had my coffee, I meant to say my components become TRANSPARENT. You can see above there are lines in front of the tree relating to the house behind.

Actually, on another model they did become invisible, but i fixed that by pasting the entire model into a new file and that fixed it. I guess the file was corrupted.

You list two graphic cards, SU should be using the Radeon and not the Intel.
I’m not a mac person so I can’t tell you how to force one or the other.
But within SketchUp go to Preferences/Opengl and Click the button for Graphic details and see what it says there.

As for your resellers bias for PC, that is his problem.

Under energy saving setting on the Mac you can tell the computer to only use the higher card (though supposedly it should do this when there’s enough power).
In SketchUp styles in the Face tab, set your transparency quality to nicer. See if that helps. I’ve seen effects similar to this with png images or textures. You might also check the edge settings. Try a default style that comes with SketchUp to compare.

Generally, PNG textures with transparency tend to misbehave when the Transparency Quality setting (in your style) is set to Faster.