Sketchup Pro 20 shading issue

Hi, I’m having multiple problems with Sketchup Pro V20.1.228 since installing MacOS Catalina V 10.15.5 (19F101) earlier this week. The file I’m working on won’t show surface colors or textures, and won’t highlight selected surfaces. In fact, it doesn’t want to highlight lines easily either on the first or second try. Also, Zoom and Orbit are super slow and jerky. I’ve attached a screengrab of the file I’m having the problems with. I can’t get shading or textures to work. Please, help. I’m, on a tight deadline. Thx! --rob

Looks like you’re in ‘Wireframe’ mode:

Choose ‘Shaded with Textures’ instead:

I don’t think so :thinking: we can obviously see some faces in the screenshot.

Oh, right — I missed that. Still, it’s most likely a style setting issue - maybe Monochrome with X-Ray on?

If not that, it’s a graphics card / driver problem.

1 Like

How about sharing the .skp file so we can see what you’ve got?

The things you describe do sound like graphics card/driver issues. Your profile says there is no graphics card. If that’s really the case, that would be your problem since SketchUp relies on the computer’s graphics card to generate the view of the model. I suspect there really is a graphics card and it could be helpful if you tell us what it is.

Thx for your quick responses!

I have Shaded with Textures selected so that’s not the prob. This problem showed up right after I updated to MacOS Catalina V 10.15.5 so I’m wondering if there’s a connection.

I’m using a Macbook Pro (2017) so it only includes the Radon Pro 555 graphics that it came with it. See the attached image.

I’ve also attached the problematic file. Have at it!

Any other ideas? I’m ready to try to reinstalling Sketchup Pro 20 next…

Vehicle Planograms 1b.skp (4.3 MB)

So your computer actually has two graphics cards? Which one is SketchUp using? Look in SketchUp’s Preferences>OpenGL.

Wow, that is a funky orbit. Just checking this out now. Looks the same on my machine, playing with it to find a reason…

I copy pasted into a fresh file to work with it and the faces are all painted transparent. I am able to re-paint them easily in a new file. Something is not heathy with your first file. @DaveR does the original file have a jumpy orbit for you?
Edit: Never-mind it was the camera set to parallel projection and in a very odd position relative to the model, this also prevented me from selecting a face at first. Camera to perspective fixed it all.

You’ve assigned transparent materials to a number of faces. Some appear to have been delete, too.

You also have some faces incorrectly oriented.

Select the individual faces. Some have one transparent material applied to both sides. (See the color swatched in Entity Info.

Others have a different transparent material applied to both sides.

While yet others have different materials applied to each side.

For the faces that are missing, get the Line tool and trace an edge of the opening.

That is the normal report on a MBP when SketchUp is running. It will use the Radeon graphics (you can check in SketchUp’s OpenGL preference if you like).

Great. I’ll paste the objects into a new file and make the update you’ve mentioned.

Thx a ton Dave & Riley!

Just switch the camera to perspective. I only copy-pasted because I did not catch on that it was a camera problem as soon as I should have.

Why go to the trouble of pasting it into a new file?

There were some far away troublemakers. I got rid of those and the model is ok in parallel projection as well now. This doesn’t have the material related fixes in it.

Vehicle Planograms 1c.skp (4.3 MB)

Works great now!

Thanks a ton Colin, Dave & Riley! Sacred my ass.

Enjoy your weekends!

Whereas mine is sacrosanct!


Haha —that supposed to be “saved”!


1 Like

Yes. The MacBook pros have an integrated card and a dedicated card. There is no need to change any settings to specify one. It should work out of the box.