Where did my plugin download disappear to?

Hi Everyone,

I am a bit of a newbie with Sketchup and still learning the ropes. I attempted to download a plugin through the Extension warehouse. I hit the download button and everything appeared to go ok.
Problem is, I cant find it anywhere.

I have looked in all the usual places but cant find it. When I look in the “My Extensions” area of the Warehouse, it gives me the option of disabling or uninstalling it. I assume it thinks it is there.

The Plugin concerned is call, "fredo 6, bezier curves "

Any ideas?

Did you also install the Libfredo extension that is needed for it to run?

No! I didn’t realise I had to… Thanks for helping. How do I do that?

Hang on, Bezier Curve by Fredo isn’t in the extension warehouse?

This is what I am finding…" Bezier Curves through points

That isn’t by Fredo6.
Did you read the how to use instructions and look for the tool in the Draw menu.
Bez

Yeah, I did that but it is not appearing… Maybe I should try again but I think that was the second time.

Thanks

Did you restart SU?
What version of SU are you using?

its 2014 pro… I tried restarting but not making any difference…

Did you use the EW from within SU or via a browser?
Did you get an Install button or a Download button?

Tried from within SU. Not sure if it was install or download button sorry…

Go and look in you default download folder and see if there is an .rbz in there for it.