Help with Plugins

advice

#1

I’m having problems with Fredo round corners. I tried to download from the extension warehouse while inside sketchup … it downloaded the file, but left it in my download folder … so it doesn’t launch w/ SU. I’ve tried to physically move it into sketchup, but am uncertain as to which folder. Currently it is in c:/program files/sketchup/sketchup 2016/tools. Is there a better folder for it?


#2

I assume you use SketchUp’s built-in Extension Warehouse (A)? But when you say the file went into your downloads folder it sounds more like (B).


There are two ways to install plugins:

  • A) in SketchUp’s integrated Extension Warehouse browser, you click “Install” and SketchUp cares about everything (that means the user does not even see the extension’s files).
  • B) through a web browser by navigating to the Extension Warehouse and downloading a .rbz file (zip archive).
    • a) You can either install it through SketchUp in SketchUp → Window → Preferences → Extensions or SketchUp → Window → Extension Manager by selecting the downloaded .rbz file.
    • b) Or manually by right-clicking the .rbz file and unzipping it with your operating system’s default archiver (e.g. file-roller). Then move the unzipped files (extension_name.rb and a folder extension_name) into SketchUp’s plugins directory, which you find on Windows in:
      c:/users/username/Application Data/SketchUp/SketchUp 2016/SketchUp/Plugins/
      or analog in Wine: /home/username/.wine/drive_c/users/username/…

#3

Easy! Open sketchup, click the WINDOW menu, click Extension Manager (not warehouse), then click Install, and find it in your Downloads folder. :slight_smile:


#4

Thank you for your quick response.

I was trying method A: Window>Extension Warehouse … the warehouse opens,
but when I go to login I frequently get an error stating:

Error while setting the setting the session value for:
appinfo
Reference ID:
ad42d0d5-739e-488a-91b8-20a068753557

When it does let me in … I search for Fredo rounded corner
Once this comes up, I click on “Install” … and am immediately taken to
SketchUcation.

I just watched a video that walked through loading using preferences. This
seems to be working.

Thanks!


#5

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.