Installing extensions (Ubuntu 16.04)

2016

#1

I’m currently running SU 2016, with WINE on Ubuntu 16.04 on am ASUS X550LA with 12Gb. I’d really appreciate some help with adding extensions, as by default all downloads end up in Ubuntu and SU “Wine” cannot find them, is cut and paste an option?


#2

Can you be more specific? Please describe step by step what you did.

…is sooo much ambiguous. How did you download them, in Firefox (as .rbz files), or in SketchUp’s integrated Extension Warehouse browser? And where do they end up, on your desktop, in your home directory?

There are two ways to install plugins:

  • A) in SketchUp’s integrated Extension Warehouse browser, you click “Install” and SketchUp cares about everything (that means the user does not even see the extension’s files).
  • B) through a web browser by navigating to the Extension Warehouse and downloading a .rbz file (zip archive).
    • a) You can either install it through SketchUp in SketchUp → Window → Preferences → Extensions or SketchUp → Window → Extension Manager by selecting the downloaded .rbz file.
    • b) Or manually by right-clicking the .rbz file and unzipping it with your operating system’s default archiver (e.g. file-roller). Then move the unzipped files (extension_name.rb and a folder extension_name) into SketchUp’s plugins directory, which you find on Windows in:
      c:/users/username/Application Data/SketchUp/SketchUp 2016/SketchUp/Plugins/
      or analog in Wine: /home/username/.wine/drive_c/users/username/…

#3

Thank you for your response, I’m sorry for the ambiguity. I have used SU for three years with Windows and have downloaded a number of extensions whilst using that format. However as I said I switched to Ubuntu and things have changed. However here are the steps I follow:-

  1. Start SU
  2. Log into Extension warehouse.
  3. Chose the extension click download. This shows up in my Ubuntu file system.
    Now when I open SU and choose preferences Install Extension the following happens.
    A small dialogue box opens in which I can find SU and Plugins folders, but Plugins is empty.
    However after reading your response I checked the Wine folder in a linux terminal the “s_bezier_110.rbz_FILES” is present as directory with the su-bezier file in it. I unzipped the file and have a su_bezier.rb, however after trying to install extension was told “Cannot install this extension”. I copied the “su_bezier.rb” using my terminal into SU plugins, but it still is not showing up in the Dialogue box(WINE). Also I cannot show hidden folders in the dialogue box to allow me to select it for installation.
    Summing up:-
    Extension downloaded and unzipped/copied into folder in Ubuntu./Doesn’t show in dialogue box in SU with “Preferences Install extension”/Search filter offers .rbz files ONLY/When I enter *****.su in “Open” response is "File does not exist"
    Any way I’ve got further thanks to your input which I really appreciate, I’ll keep trying.
    Hal.

#4

Latest development:-
I re-copied the file via my terminal just in case, and restarted SU and the su_bezier.rbz showed up and was “Successfully installed”, however it is not showing up in any of my pull down menus. Is there anything further I need to do, as I’m fairly certain under Windows the extension settled itself into a menu with no help from me. Your help is appreciated.
Hal


#5

Secret trick: you can move files using the file manager (Nautilus, toggle hidden files with ctrlH).

I’m still not sure if some of the alternative ways were mixed up. Let’s check the current situation. Please, use your file manager and navigate to /home/hal/.wine/drive_c/users/hal/Application Data/SketchUp/SketchUp 2016/SketchUp/.
There should be the following folder structure:

This extension should add a menu item in Draw → Bezier Curves.


#6

Thank you again, I appreciate your time and efforts.
To clear up a point when I refer to the"Dialogue Box" it is the one that appears when Clicking “Install extension” and no keyboard commands are recognised, mouse selection only. However I went searching and here is a text of the results of the search:
hal@hal-X550LA:~/.wine/drive_c/users/hal/Application Data/SketchUp/SketchUp 2016/SketchUp/Plugins$ ls -la
drwxrwxr-x 8 hal hal 4096 Jul 17 09:24 .
drwxrwxr-x 4 hal hal 4096 Jul 17 15:01 …
drwxrwxr-x 4 hal hal 4096 Jun 12 10:34 su_advancedcameratools
-rw-rw-r-- 1 hal hal 1715 Feb 24 2016 su_advancedcameratools.rb
drwxrwxr-x 2 hal hal 4096 Jul 17 09:24 su_bezier
-r–r--r-- 1 hal hal 1784 Jul 17 09:24 su_bezier.rb (Only 1.8kB Ruby script)
drwxrwxr-x 8 hal hal 4096 Jun 12 10:34 su_dynamiccomponents
-rw-rw-r-- 1 hal hal 1780 Feb 24 2016 su_dynamiccomponents.rb
drwxrwxr-x 3 hal hal 4096 Jun 12 10:34 su_sandbox
-rw-rw-r-- 1 hal hal 1706 Feb 24 2016 su_sandbox.rb
drwxrwxr-x 8 hal hal 4096 Jun 12 10:34 su_trimble_connect
-rw-rw-r-- 1 hal hal 1339 Feb 24 2016 su_trimble_connect.rb
drwxrwxr-x 2 hal hal 4096 Jun 12 10:34 su_webtextures
-rw-rw-r-- 1 hal hal 1299 Feb 24 2016 su_webtextures.rb

As you will see I have a directory named “su_bezier” in the list.
When this is opened it shows:-
hal@hal-X550LA:~/.wine/drive_c/users/hal/Application Data/SketchUp/SketchUp 2016/SketchUp/Plugins/su_bezier$ ls -la
total 28
drwxrwxr-x 2 hal hal 4096 Jul 17 09:24 .
drwxrwxr-x 8 hal hal 4096 Jul 17 09:24 …
-r–r--r-- 1 hal hal 13866 Jul 17 09:24 bezier.rb (13.9kB Ruby script)
-rw-rw-r-- 1 hal hal 88 Apr 30 2013 extension_info.txt

Quite a difference in size.

Thanks for the tip on ctrl + h, I was aware of it but as I said it doesn’t seem to work in the "Dialogue box"
As you’ll see I went looking via the terminal where “ls -la” gives me what I need, but I can provide a CAJA screen shot if that would be better.
I tried re-starting SU and all the Draw menu shows is Lines Arcs Shapes Sandbox, (all with drop downs).
I really appreciate your help, I enjoy “rooting” around my system but must admit I am apprehensive and very new to the concept.
Hal.


#7

that’s read only in unix world, change the permissions to rwx [read write execute] and it may work…

john


#8

That dialog box is a file selection dialog (to select the .rbz file); to be precise, it is a Windows file selector, thus Ctrl+H is not available.

The files seem to be in the correct place. File permissions should not be a problem (the execute permission is only needed when executing the file stand-alone, but here SketchUp reads and interpretes the file). Since the “Sandbox” extension is loaded, we should look for a difference between Sandbox and Bezier.

  • Extensions are not globally disabled through Sketchup.plugins_disabled (we know that already)
  • Is the Bezier extension not enabled? Take a look at the checkboxes in Window → Preferences → Extensions.
  • When you manually load the extension, what happens? I’d expect we would have seen a load error already when starting SketchUp. Try this:
    Open Window → Ruby Console and paste:

load "c:/users/hal/Application Data/SketchUp/SketchUp 2016/SketchUp/Plugins/su_bezier.rb"
load “c:/users/hal/Application Data/SketchUp/SketchUp 2016/SketchUp/Plugins/su_bezier/bezier.rb”


#9

Thank you again, I do not have Ruby console available from the Windows Tool bar.
When installing Wine/SU I was told to disable Ruby. The set of instructions is on:-
https://sysads.co.uk/2016/08/05/install-google-sketchup-make-2016-ubuntu-16-04/
See "Open Sketch 2016 properties menu, under command, add ‘/DisableRubyAPI’ at the end "
Possibly it is as I’ve begun to suspect, my installed version does not have the facility to run Ruby scripts.
In answer to point 2 In the dialogue box selecting Extensions shows nothing. At one time after receiving “Extension successfully installed” su_bezier (or something similar) was displayed, but not now. I have “Policy” set to unrestricted.
Also the “Draw” menu no longer has Sandbox as an option.
I really appreciate your efforts however I am becoming concerned at the time you are spending on this, if it is a problem I can exist without the facility of creating bezier curves.
Hal.
When I search via the Dialogue box through c/Program Files (x86)/SketchUp/Plugins. (Search filter Ruby files *.rbz) there is nothing.


#10

Thank you John, however on the Properties dialogue I can only change permissions to read and write. I’ve read I can change permissions via the terminal but am not totally confident in trying.
Hal.


#11

on my mac ls -la is formatted a little differently, but folder at the same but the extension file as read/write

drwxr-xr-x    4 johns_iMac  staff      136  2 Jan  2017 su_bezier
-rw-rw-rw-    1 johns_iMac  staff     1784 23 Apr  2013 su_bezier.rb

when I run it on the folder

drwxr-xr-x   4 johns_iMac  staff    136  2 Jan  2017 .
drwxr-xr-x  86 johns_iMac  staff   2924 14 Jul 03:32 ..
-rw-rw-rw-   1 johns_iMac  staff  13866 23 Apr  2013 bezier.rb
-rw-rw-rw-   1 johns_iMac  staff     88 30 Apr  2013 extension_info.txt

again read/write…

this is a recent fresh download using Extension Manager…

john


#12

Why didn’t you tell this first (you probably didn’t know). This advice is nonsense. SketchUp’s extensions are written in Ruby and rely on Ruby. By disabling Ruby users opt out from the possibility of using extensions.

Please enable Ruby by removing /DisableRubyAPI from the start parameters and try again.
Does it load the bezier tool now?


#13

Aerilius
Thank you again, it was only after re-reading the installation process I remembered the “Disable…” command, I am sorry if it has wasted your time, it is such lack of knowledge that brands me a novice.
I removed the command and the bezier command did not load, but Sandbox was once again showing, and a number of extensions were showing in the “extensions” dialogue, all ticked, and amongst them was the su-bezier.
But the Bezier tool was not available, however the ruby console was then available and so I cut and pasted your suggested line into this with the following result:-
load "c:/users/hal/Application Data/SketchUp/SketchUp 2016/SketchUp/Plugins/su_bezier.rb"
true
And Bezier curves has now appeared under the draw menu.
It would appear I have to paste the load command each time I open SU, for when I shut down and restarted the program, Bezier need a “forced” load as before. Is there a way I can make it permanent?
Thank you once again for your help it really is appreciated.
Hal.


#14

John,
Thank you for your time, I’ve picked up some useful knowledge from your answers. You will have noticed I am working through another answer at the moment and the problem seems to have mainly resolved itself. Thank you once again, it is good to have such support and people as yourself that give freely of their knowledge and time.


#15

Aerilius

I felt I’d rather respond outside the forum as what I want say is not
relevant to the thread, and thank you for your time. I enjoyed using SU
on Windows for furniture design which I then hand made. At 80 I am
spending less time in the workshop as and more on the computer. I was
concerned over Windows security and so made the shift to Ubuntu, and am
slowly building knowledge and confidence. Following you advice I have
learned quite a deal more about my system.

Thank you again.

Hal.


#16

John,

Just a short thank you “off line” as it were. I appreciate your advice
and used it to explore my system further. At 80 I am spending more time
on the computer and as having recently left Windows for Ubuntu any help
is really appreciated.

Thank you again.

Hal.


#17

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.