When zooming or orbiting, the screen shows previous views at the same time than the new ones

1 Like

This is a graphics card issue. In SketchUp, go to Window>Preferences>OpenGL. change the state of the tick box for Use Fast Feedback. Tick the box if it isn’t. Or untick it if it is. Do you see an improvement?

Your profile is confusing because it indicates a version that doesn’t exist. Your screen shot shows SketchUp Pro not SketchUp for Schools. Please update your profile with the right information and at the information for your graphics card. (6 GB is not the graphics card.)

2 Likes

Thanks, I did what you told me to do and it worked.
I will update my profile also.

1 Like

Glad to hear it worked. Did you untick the box or tick it?

Pretty sure he checked the box. I think this is one of those cases I’ve mentioned elsewhere, where it is an Intel GPU, but more powerful than the ones in Surface Pro. Turning off use fast feedback in those cases does lead to these artifacts.

I ticked it, it was unticked.
Thanks again.