When using Match Photo, textures and color don't appear


#1

When using SketchUp’s Match Photo function, the model’s colors and textures do not appear. Instead, they are replaced by the default green ground color and I can’t for the life of me figure out how to make the colors and textures appear. I know they’re there because when I leave the Photo Match function they appear again. I’ve literally spent hours going through online forums and tutorials trying to figure this out to the point where I’m quite familiar with the Styles dialog and the various functions contained therein. For e.g. when I select and update the face style “Shaded with Textures” it does not seem to do anything although the other face styles (wireframe, x-ray for example) show up no problem. Obviously there’s something I’m missing here. Any help would be deeply appreciated


#2

Have a look at the Styles docker - Edit tab - Modeling button; there are a couple of sliders for foreground and background opacity.

Also note that the photo-matched photo will vanish as soon as you rotate away from that scene*: r-click on an object within the scene and “Project Photo” to map the photo onto the faces. (click on the scene tab to rotate the model back to the correct position)

(* you can pan and zoom, but any rotation will move away from that specific viewpoint, so the photo is no longer applicable.)


#3

Thank you so much! I’ve actually been playing with the background and foreground photo sliders to no effect then your response made me revisit that aspect and I realized the foreground opacity slider has to be unchecked and not just put to 0 which is what I was doing before.
thanks for saving me more hours of fruitless searching


#4

I ran into the same issue and was desappointed not to find a solution in this thread. I was lucky to eventually find the solution myself. It’s actually very simple once you know it.

1/ Make sure you see the tray on the right of your screen ; otherwise click window / default tray / show tray
2/ Make sure the Styles dialog is part of the tray ; otherwise add it through window/manage trays
3/ Make sure you see all of the Styles dialog by enlarging it ; weirdly I had to to click the ‘display secundary selection pane’ (upper right corner of the dialog) before I was able to enlarge the dialog
4/ In the “Match Photo” section of the Styles dialog, unclick “Foreground photo”. Note that setting the opacity to zero is not enough. I think the background photo opacity needs to be 100%.

That’s all.


#5

I used the steps above and now I can see my rug on the floor of my match photo, but the flooring is now really dark and I can’t see the match photo floor. Any suggestions?


#6

Share the file so we can see what you’ve got set up.


#7

…or even a screen shot of what it looks like.


#8

Room Example with Foreground Off.skp (1.8 MB)


#9

This is with it foreground onRoom Example with Foreground On.skp (1.8 MB)


#10

You will notice that you can no longer see the floor texture.


#11

One problem is that the faces are reversed.

As for the floor appearing dark, that’s due to the orientation of the camera relative to the face of the floor. You can turn on Shadows and adjust the Dark slider to the right. Or just turn on Use Sun for Shading. Adjusting the time of day and the date can also help.


#12

Thanks so much! I will try that. Really appreciate your help!