When import dwg hangs at 99%


#1

Hi, when importing dwg into sketchup it hangs at 99%. Sometime it does allow the import but not often and I’m forced to cancel as its taking too long.
I have tried reducing the file size by removing unnecessary layers purge, audit the file in Autocad but to no avail the file is about 4500 bytes.
Does anyone have the answer…


#2

Post the model if you can, otherwise we’d just be guessing.


#3

Thanks for your reply. Unfortunately I do not have a model as I am not able to import the dwg. Once I can do that I will be building the model. The dwg is an architectural plan drawing of houses.


#4

You mean 4500 kilobytes? That is quite large. The import progress bar in SketchUp is somewhat misleading. With a large file, what happens when the bar is at about 99% is that SketchUp then starts to convert the imported entities into SketchUp objects, and typically this takes longer than the previous stage, and with no indication of progress, while SketchUp appears frozen. Have you tried just leaving it running for a while - the process is known to sometimes require even hours?
You can also post the DWG if you want answers that aren’t mere guesswork. Are the plans created using AutoCad Architecture walls and other objects? In that case you have to export them to “plain vanilla” AutoCad from the application prior to importing.

Anssi


#5

Hi thanks for your reply.
would you please explain what you mean by "plain vanilla ". I have left the running of the import for quite a while but the PC crashes and stops responding. I also thought that 10000kb was max and my files are half that. If I have to leave the running for more than 10 minutes it becomes not practical to use sketchup
Regards
Sent from my iPad


#6

Plain vanilla as in “non-proprietary” elements.

DWG/DXF Supported CAD Elements — SketchUp Help
http://help.sketchup.com/en/article/114365

How should I prepare a CAD file for import into SketchUp? — SketchUp Help
http://help.sketchup.com/en/article/38578


#7

Hi
I would like to thank all those who have responded to my query.
I have tried all the methods and some extra ones, which no-one has mentioned so far
but Sketchup stills hangs at 99%. I have also tried additional plugins. If it is doing
something in the background it would
be nice to have some indication that it’s still alive (progress bar or reducing
numbers). This problem has been going on since version 8 and it seems nothing
concrete has been done. This method of importing does work for small projects
and I have seen many tutorials showing how simple it is to import a DWG, but these
projects only have a half dozen lines. The dwg I have has thousands of lines.
Someone showed a tutorial how to bring in a PDF that worked well,
but try a larger file and Inkscape crashes as well.
I am also surprised that sketchup cannot import PDF. Surely it is a
must in this day and age.Sketchup is good to use
for small projects but not massive projects which I am working on at the moment.
I hope someone is listening and will take notice if Sketchup wants to be considered being
a serious 3D contender.


#8

As said, if you could post here a DWG that you are having problems with, someone here could take a look inside. My access to AutoCad is a bit occasional during my summer holidays.

The 10 MB you refer to is the size limit of files posted on this forum. The only limit to files you can import into SketchUp is the amount of available memory which shouldn’t be a problem, especially with the 64-bit version.

Anssi


#9

Thanks for prompt reply. Unfortunately I cannot send you the dwg as this project is under construction and the author will not agree to me sending the file. Even if I get past the import will sketchup be able to cope with 14 drawings at one time.
Regards thanks for your help


#10

Just had a thought What would you be looking for in the dwg. That may be causing a problem. What about using archicad in some way.


#11

All geometry must reside on the Default Layer 0 in SketchUp.
And like Anssi says, SU cannot recognize AutoCAD Architecture walls and other ‘proprietary’ objects.

You might try breaking up the original file into a set of smaller, properly prepared files.
That is, export to AutoCAD certain layers from the original CAD file to separate files for import into SU.
Therein, reassign all geometry to Layer 0 prior to import into SU.

Bring into SketchUp only what you need and in a form it can recognize.
Delete and purge all else from the CAD files prior to import into SU.

Unlike the image below…
A properly prepared CAD file will indicate no AutoCAD Entities Ignored in the Import Results.


#12

Same problem with me. Trying to import 3d CAD data for a hearing. Shrunk the CAD file quite considerably. The import just hangs at 99% for the last 20 minutes now. Merging / importing message. Partly think this is need to modernize the importer. R14 is from 1997!?! 2016 is R30. I’ve tried other work around ideas. Importing to Cinema 4d then exporting obj. But the import then still takes forever. SketchUp needs to really push to modernize these importers for PRO user applications.


#13

Still importing that same file… 29 min ago? So that’s 49 minutes… What a joke. Says “importing entities” now.

Update: Total import time of 544mb DWG 1 hour. Got the whole neighbourhood in there… Purged geometry, copied the contents to a new file and got the file down to 2.7mb. Still amazing it too that long. The same experiment into C4D took a grand total of 20 seconds.


#14

For clarification… was it a 544MB DWG file? … or the resulting sketchup model was 544MB?

Do you know what software created the DWG?

CD


#15

I would say that was actually quite fast, and it is amazing that it was doable. Did you check SketchUp’s memory usage while importing?

I have never met a DWG that large. Some of my BIM projects in Archicad or Revit are around 100 MB.

Anssi


#16

Hi there. Purge your AutoCAD file before importing it in sketchup.
Otherwise please forward to me your file.
Thanks.


#17

Just like in SketchUp files, the size of the file tells you little about what is inside because the .skp and .dwg formats store much more data than just geometry.

For mesh files such as .stl and .ply - file size is a good indicator of the resulting model size because these formats store only geometry.


#18

I am having the same problem with a Cad file that is only 17mb. Ive imported many file before


#19

I meant to say that I have imported many dwg files before with no problem


#20

a) refer to the links Geo posted (above):

b) No one will be able to give you any feedback unless you post (or give a link to) the DWG file.