Large Model / Drawing Options


#1

Hi,

I need to create a large model for a friend (my first official project :slight_smile:

The building is 210 meters long and 120 meters wide.

He has given me both CAD and PDF drawings of the building.

I’ve tried importing the files into the SketchUp and here is what has happend:

  • SU crashes as soon as i try import the CAD drawing (Macbook: 1.7ghz with 4GB ram)
  • the PDF import is very poor quality when i scale it to size, so it is impossible to trace
  • i’ve tried ourputting the CAD drawing at 300dpi in .jpeg and .png but they also loose quality when i try scale them to size

I read somewhere that SU automatically reduces images to 1024 regardless of the size you import… is this true.

Can anyone recommend a way to get the plan into SU so i can start tracing at the real scale size (210m X 120m)

Thanks in advance for your help


#2

SketchUp and OS version?
Have you tried with extensions disabled?
Did you submit the BugSplat? If you submit a BugSplat with some info in the description, name or email fields and let us know what you wrote we can look it up as see if we can find some clues.

Yes, unless you check the “Use maximum texture” under OpenGL preferences:


#3

I’ll add on to Thomthom’s post with some other considerations…

Regarding DWG files, note that all DWG are not created equal. We do our best to match what AutoDesk uses but ultimately they don’t provide a direct means to duplicate their effects. Because of that, the DWG you get from AutoCAD is not the same DWG you get from Solidworks. Personally, I recommend always saving back to AutoCAD 2000 when exporting from other software to ensure the best compatibility coming into SketchUp. Thom has a great post from his blog about preparing a file for export which could help; http://www.thomthom.net/thoughts/2012/12/sketchup-dwg-import-guide/

Regarding textures, you can disable the 1024 limitation but note that it is there for a reason. Inserting a large image will fill up your video card memory very fast and you may start getting errors and ultimately an out of memory error depending on how often you do this or if you tile it. Just keep it in mind if SketchUp starts misbehaving later.

Hope that helps!


#4

Is the DWG created in AutoCad Architecture (or whatever it is named today)? SketchUp cannot import directly the walls and other architectural elements from AutoCad Architecture, and it may even crash if these are present in the file. AutoCad Architecture has an “export to AutoCad” function that will convert these into standard AutoCad objects (2D lines from a plan view, 3D surfaces from a 3D view) that should import into SketchUp correctly.

Another thing that can cause a crash is if the drawing is placed very far from the model origin (using a digital map, for instance) and you have the “Preserve drawing origin” box checked in the Import options.

Just suggestions.

Anssi


#5

Thanks guys.

I turned on ‘use maximum texture size’ in the Open GL preference so now i am able to import a large png image, however i haven’t even drawn a line yet and my file is 7mb.

I plan on deleting the imported image plan as soon as i have the base of the model drawn on top if it.


#6

most likely that your CAD file import entries damaged, or too many unused files 2D. try to remove the remnants of unused files that work such as the size or the line, after a clean 3D files from 2D file, try exporting again … hopefully helpful, greetings