Partial render of model after import of DWG


I’m a bit of a newbie here and I’m having some trouble with an import of a 3D DWG file.

The model file size is about 500MB so pretty large, after the import the model was only showing an outline, after a while only a small portion of the model has rendered correctly where I have solid walls,staircase etc. The rest of the model is still in a outline format.

I have exported as a SKP file in order to work with it in Sketchup Make.

Any idea what I’m missing?

I have attached a snip of the model which hopefully makes more sense…

An adequate graphics card is my guess. Go to Window>Preferences>OpenGL and turn off Hardware Acceleration. See if that makes a difference.

How will you be using this model once you have it fixed up?

500MB is a very big file. I would not be too surprised if you had importing issues!

Can you share a little more about where the file came from? You said that you exported an SKP file, was that from another cad software?

Can you export a smaller section and see how that imports? I am guessing that the size of the file you are importing has something to do with your issue.

Thanks for the quick responses…

I thought graphics card but I’ve had no issues with importing models form the 3D warehouse before.

The original 3D DWG file came from an architect using Autocad, I then imported into Sketchup pro. I have since exported as an SKP file so I can work with it in a sketchup format.

I have requested they send me a broken down file so I will try that.

I work for a well known IP camera manufacturer and we have our cameras and bracketry as extensions into Sketchup to show how a camera solution would look and what the camera will see at a given level of detail. This is my first real foray into 3D as we see that more architects are sharing 3D CAD model as a basis for a network video design.


Did you try turning off Hardware Acceleration anyway?

Since its for commercial work you should be using SketchUp Pro, not Make.

1 Like

I’ve not long had Sketchup Pro installed, and just finished the trial so I’m on make.

I’m in the process of getting a pro licence.

Yes, tried turning it off but no change…

Did you restart SketchUp after changing OpenGL settings?

Another possibility is that the faces you expect just are not there. Are you using a very small import unit when importing the DWG files? What AutoCad tools has the architect used to create the model? If he/she has used walls etc. from AutoCad Architecture, have they been properly converted to standard AutoCad 3D face geometry prior to importing the model into SketchUp? Can you post a part of the DWG file?