Can't see my imported dwg file in my skp file

Hi everyone! I am trying to import a DWG file to sketchup that includes buildings and roads, it takes a long time too import and after it is completed, I can’t see my imported file even though the layers appear in the default tray.

I tried to change the placement of the layers and put it in the origin on autocad but didn’t work.

Can you please help me about it? I really need to import the file and start modelling the buildings and everything by tomorrow. Any help would be appreciated, thanks in advance for all.

I just responded to a post with the exact same text on Sketchucation. The person who posted that indicated they are using SketchUp 2015 Make. Your profile says you are using SketchUp 2017 Make. In either case there is no option to import a .dwg file so how are you importing the file? Share the .dwg file so we can see what you are starting with.

May not be the case with your scenario, but when I use import, it requires a “click” to position the origin and then with large imports, I follow with “zoom extents”.

I tried Zoom Extents and now I can finally see my file, thanks a lot. What I did to import was file>import and then selecting the dwg file I wanted to import. I used Sketchup Pro 2017 and the dwg file was saved as AutoCAD 2000 version. I appreciate your replies. It was really quick and helpful.

However my SketchUp gets super slow over a 17 MB file import, do you have any suggestions on how to fasten it?

Again. I replied to your thread in Sketchucation.

Please correct your profile.

Again, just my workflow, but when I import large dwg files, I then follow with model info>statistics>purge unused and then fix problems. Hope this helps …