Huge Import - big problem

I am trying to import a large DWG file - of around 440Mb: it originates as an export from Autodesk (the 3DS file is 2.3Gb - it is a detailed model of St Pancras station in London - I want the detail). My machine is 16Gb ram, i7 7700 processor, running @ 3.6Gz, with loads of drive space, twin screen. I’m using Pro 2022 because it looks like 2023 is not yet reliable.
So far, the DWG file seems to be successfully imported (no error messages, on completion; on screen report said - 20 layers, 1232 blocks, 28,873 inserts, 1759 sub-meshes, etc, only 1 zombie) - and the autosave seems to happen: but then nothing. No render, no model visible - the [calculating] circle continues to turn, but never gets anywhere - even hours later.

By the way, I even tried importing the 3DS model, and it got to 80% before falling over badly, crashing one screen - and making reboot the only way forward. No error messages. No failure messages.

I don’t have access to the original model - nor to Autodesk - so right now my options are limited.
Has anyone any ideas?

Try to import the 3ds file with Universal Importer extension.

You can try tweaking the import options. Check the import unit. It should be set either to tha same unit that the DWG file uses, or if the detail is very intricate you can try using a bigger unit than the original (like matars instead of centimeters) to avoid very short edges and resulting missing faces. Another is to not check the “preserve drawing origin” option. The model might be using a map coordinate system that places the model too far from the SketchUp model origin point.
The file is massive. Even letting the import run overnight might not be enough, but if the circle keeps turning it is an indication of the importer keeping on working. Crashing would produce a bugsplat. The indicator SketchUp displays when importing is misleading. When it gets to 99% it has only just read the file into memory and the real work is only beginning.

Hi David, if you can share the file I’ll be happy to see if I can get it to work here - I’ve got a selection of tools to try.

Hi Adam, sorry, I bought it and the Shutterstock licenses…

To check memory level Press Ctrl+Alt+Delete to open Task Manager and use the Performance monitor to view your system memory (RAM) levels. You’ll see it filling up.

On import and first load, a file can use a lot of RAM. It doenst crash but it will sit and grind away for a very long time.

I’m dealing with a 400mb DWG myself at the moment and it requires approx 30GB of RAM to import. Once loaded, this drops to around 24mb.

I suspect you’ll need more memory…but how much more is difficult to say.
If yours is a desktop PC then now’s a chance to upgrade to 32 or 64gb. Otherwise ask somebody else with a free hour or two to open and save out the model into smaller chunks for you.

Tips when dealing with large imports:

  • Turn off sketchup edges and profiles before you import (and shadows and anything else that is even a little bit fancy).
  • Turn off autosave (you can turn it back on later)
  • Import to a clean SKP file - nothing else inside it - Once imported and you get the chance, save the model as a SKP file and then reopen it.
  • Do not choose “preserve origin”.

Checking memory usage is a good idea when a task is taking vastly longer than seems reasonable. On all modern computers, if an app allocates more memory than your actual RAM, the OS starts swapping chunks back and forth to disk (“virtual memory”) which even with SSD is an order of magnitude slower than RAM. But, if your RAM is not overbooked, there must be a calculation taking place that is very time consuming. Some algorithms don’t scale well for large amounts of data.

Thanks for this info. I have ordered more ram.

Thanks for this, very useful. I’ll try that, and get more RAM.

Have you tried AutoDesk DWG TrueView ?