When I try to hide an item in my model it leaves like a wire mesh looking screen


#1

When I try to hide an item in my model it leaves like a wire mesh looking screen


#2

Turn off Hidden Geometry in the View menu.


#3

Thanks ! Still learning, never stop learning!