What is the best way to generate rounded 3D 'solids' like this...?


#1

Hello

I need to generate something that looks roughly like this:

Are there any special tools or plugins that would help me generate this sort of thing more easily? I will need to 3D print it so presumably it will need to be ‘Solid’ when I finish.

Background

  • First I tried using extrusions of circle down paths…
  • Then I tried using the Follow Me tool to remove volume off a square cross section (see below). But both methods are extremely painful, because Sketchup it keeps going wrong in many different ways…

Problems: e.g.

  • gaps in the surface,
  • surface randomly need to be Reversed,
  • new surface is out of position
  • various error message about the path - (yes, even when the path it’s following is derived from a very simple circle).

What I am trying to do is conceptually quite simple!
a) most of the thing needs to be rounded (to the same radius)
b) I need corners in the overall Silhouette/outline of to match given radiuses (radii).

There must be an easier way!


#2

??

Follow Me worked just fine for me. No gaps, no problems. Solid component when finished.


#3

I see the surface you used, but what outline did it follow?


#4

Probably something like this…


#5

DaveR - how the *heck *did you do that?

In particular, was there something clever about the way you created the initial 2D shape? (Which I assume you then extruded using the Push-Pull tool, and then did the follow me tool on, like Cotty says, yes) Do all the rounded corners have the EXACT same radius - if so how does one do that? Do you use the Tape Measure tool each time and then the “2 point arc” tool, and then double-clicking when you get the magenta “Tangent to Edge”?

Yes, I can of course build all that stuff but, when I do it I definitely get errors downstream when I use the follow me tool round on an extrusion. Or are you using the Offset tool in some way? Maybe the fact that I increased the number of sides of the original 2 circles (from 24 to 48) is getting me into trouble.

Likewise, are you drawing all the lines or using shapes (circles + rectangles) which you then join up?

Cotty did you find no errors too? And where you able to create as solid at the first attempt?

Or maybe I’ve been generating my shape to cut with using the Follow Me tool incorrectly in some way?? (For one thing I was only doing one quarter at a time, which now seems like a mistake…). Fwiw, I have been trying to work at large scale in whole meters (EDIT: actually I have some 0.5 meters - could that be source of errors??), - with a plan to shrink by x1000 before export for 3D printing - could that have been a mistake??

I must have been doing something badly wrong… [sigh!]

P.S. In particular how do I get my correct standard radius into a shallow corner - e.g. onto a circle:


#6

There’s nothing wrong with a quarter solution, there are many ways to get that result…


#7

Instead of the subtraction method you can create the round parts too and combine them afterwards with some lines…


#8

Instead of the subtraction method you can create the round parts too and
combine them afterwards with some lines…

Yes, my main problem with adding rather than subtracting is that the rectangular bit in the middle was hard to fill in exactly right. Either way I also got lots of errors! I think I am doing something wrong when build the initial outline… (see above)


#9

If the contours are coplanar, two lines will create that face…


#10

one way to get close using standard tools and cut >> paste in place…

EDIT: to clarify,
you need to find the intersection of the 2 radii but SU uses edges…

I started with 2 groups containing an array of edges rotated at 1 degree…

I move the smaller set down until I find a ‘close enough’ match on the end points…

I then ‘cut’ the ones that touch my target geometry…

I delete the original groups and ‘paste in place’ the two edges to use in constructing the new outline…

I the cut and pasted those into my main group and hunted around a bit to find the faces…

I could have redone it to look ‘slicker’, but sometimes you need to play with it…

john


#11

Sorry, John, I don’t understand what you mean.

Btw, is there any quick way to move things around by standard distances without typing the distance in each time.
(e.g. in my 2D illustration software - Xara - I can move by hitting select then using an arrow key - optionally with control or shift or Alt - each of which have different sizes of effect. I find it incredibly useful to move something off say five units to the left and then five units back again later and it will be exactly where I had it before. It’s quicker than Sketchup where it seem you need to select with mouse, hit m for move, then using mouse to find the correct direction and then typing in the amount and then doing the same thing in reverse. Fwiw, In Xara the movement distance depends on either grid size or how zoomed in you are depending what other modifier keys are being held down. )


#12

I guess that would work… but it does seem horribly rather fiddly. And in my experience anything ‘fiddly’ seems to screw up the Follow Me paths.

How do you create an array of edges rotated at 1 degree. (Something to do with the Rotate tool and control key I think but I couldn’t figure it out!)


#13

array edges with Rotate Copy…


john


#14

OK thanks I can now get the array paste work (although it sometimes likes to paste in dotted lines instead of real lines).

However I am now seriously starting to lose patience with Sketchup: :rage: :rage: :rage:

A) I still cant get the “2 Point Arc” tool to go magenta and snap to say “Tangent To Edge”

B) Even if I could, it seems fiddly and still feels like a LOT of steps. Isn’t there a better plugin tool out there somewhere?

C) Or can’t one just do it with circles (with a very high number of sides) in some way?
The problem with using circle is that it seems to be impossible to get them to snap into position correctly.


#15

you should probably practice on a plane rectangle, I don’t know of any plugin this easy…


#16

Yes 90 degree angles are dead easy. The 2 Point Arc readily goes magenta and snaps to say “Tangent to Edge”.

Once this has happened, after I extrude, the Follow Me tool will work without a problem.


#17

you should see how we used to have to do this sort of thing…
I’m NOT doing a demo for that as it’s way to complex…
are you using the inference repeat function?


#18

are you using the inference repeat function?

THO, I’m not sure what that is nor how I would use it.

But don’t worrym I am resigned to just guessing / ‘bodging’ the outline radii. If I can get a “Tangent to Edge” all is good and the Follow Me tools will work.