Weird group error on ipad

Hi there,
Been using sketchup for ipad for a couple months now. Im designing my timber frame house with it. So far so good, I used the tags to manage my groups, as the outliner wasnt working when I started. But now that I’m fairly far in the drawing process, I’m getting a bunch of weird groups. It might have some chances of user errors, but I really dont know how I would have done that…
Sorry if Im not being clear, I’ll do my best but its pretty hard to explain;
Lets say, using tags I hide everything and select the 2nd floor girts to isolate them. They appear, no problems.
Before this problem (and still for most of the house), when I click on one of them, it would highlight the object. Then I would double (or triple ?) click and it would enter in edit mode;
it now only selects one face, some faces, some edges or so. When I try to edit, the edges of the braces (an other group) appear and seem to be tied to it. I’ve tried everything, cant get rid of it… so now I cant even remake the group.
An other exemple, I had this one line floating in the air, not related to anythiing. Tried to delete it, but wasnt able to. Double click on it and the hole second floor of the house gets selected, but only the edges and acts like it was one big group but its not…

I’ve taken a few screeshot but cant figure how to post them on this forum… I feel like a total newb now… ahahah

Share the .skp file with us so we can see exactly how things are set up and help you get it sorted out.

That is a share file which is view only and therefore useless for us to find the problem.
You need to attach a link to a saved version of your model itself.
But my guess is you have used Tags incorrectly. You should only tag groups and components, not raw geometry.

The file is 81mb, forum wont let me upload it its too big… how should i do ?
And im well aware not to tag unless its groups. A whole bunch of groups just ‘united’ themselves…
Im looking for a way to revert it without having to restart as it took me a few months to get there…

I guessed it would be larger than forum size which is why I said a Link.
Upload to dropbox or similar and attach a link to it here.
That is too large for me as I have limited download but others will look at it.

You have to make the file accessible.

Sorry. Should work now

Yes it does.

First thing I see is incorrect tag usage. ALL edges and faces should be created and left untagged. This is the result of fixing that.
Screenshot - 1_12_2023 , 2_14_45 PM
This would be responsible for the displayed hidden geometry.

It appears you exploded the roof objects. They are all loose geometry now.

Most of the faces in your model are reversed. There should be no visible blue back faces in a 3D model.

Thanks for taking the time.
Is there a quick way to solve this or I must redo?

There’s no "instant"way to correct it from this file. If I had to fix it I would move all of the loose geometry to the side and use what I could as reference for recreating the components making sure they are modeled correctly. It also looks like there is a bunch of stray geometry that should be cleaned up. Take a close look and see what is needed. It might make sense to start over on the whole instead of chasing all the little bits of chaff.

Thanks for your time.