Webversion can't use my external GPU (Laptop)

To start of my story, I’ve used Sketchup since the time it was still a @Last software project. Always loved the simple way you can build things without paying for it as it is a hobby and not my job. At this point I’m still using Make 2017 for that reason. For a test I used the new webbased app. And I’m sorry to say it’s one of the worst webbased tools I’ve ever used. After all those great Sketchup desktop apps I expected way better.

But the biggest problem I have it that it’s extremely slow as I use it on my laptop. The main reason is that my laptop has two GPU’s. The Intel HD one for displaying and the GTX1070 for the calculations. Now we get to the problem. Where I can select the Nvidia GPU on the dasktop version, I can’t with the web version. So the webbased version is basicly unusable.

I feel like using Make 2017 is the only option as I refuse to pay, especially as I see how bad this version is and how ignorant Trimble is to all the users. At least is looks like it when I visit the forums and see all the complaints.

An application uses one or the other at a time, not both.

Open the Nvidia Control Panel and set your preferred browser application to use the “High performance Nvidia GPU”.

If you use Chrome you can check it by loading the internal page at this URL: chrome://gpu/
(May also work in Safari ?)

Nope (at least not on Mac). But it does work in Chrome on Mac.

1 Like

So does Safari have then safari:// pages instead of chrome:// pages ?

No. I get an error saying that macOS doesn’t recognize internet addresses starting with safari:

Which makes it interesting that Chrome does recognize addresses in that form. Sounds like safari blaming macOS for what it could actually do itself.

Quit the app if it’s open. Select the app in the Finder. Press Command-I to show the app’s info window. Select the checkbox next to Prefer external GPU .

john

… if on a Mac. Windows instructions above.