SOLVED: SketchupShop very slow to export DWG

I subscribed to Shop in April and all was well with exporting. I usually launch in Chrome. In the last month, the simplest of files take more than an hour, if at all. As a test, I drew 2 rectangles, saved, and exported. 2 hours later, it’s still “in progress”. Thoughts?

macOS v 10.13.6
MacBook Pro Retina, Early 2013
2.7 GHz Intel Core i7
16GB memory
NVIDIA GeForce GT 650M 1024 MB
Intel HD Graphics 4000 1536 MB

Reports like this need a version.


My Chrome just updated a minute ago to Version 75.0.3770.80 (Official Build) (64-bit)

1 Like

I am not sure what utility you use on the Mac, but on Windows the Nvidia drvier comes with a Nvidia Control Panel that can be used to force certain applications to use one of the 2 available GPUs. It’s under “Manage 3D settings” on the “Program Settings” tab.

I have Chrome set to use the “High performance NVIDIA processor”.

I also verified in the internal chrome://gpu/ page that Chrome is actaully using the Nvidia GPU.

You might also check the internal chrome://flags/ page that there are not any weird flags interfering.

(You could copy these pages to a zip file and attach the zip to your 1st post to help the technician help you.)

Hi Dan. Thanks for your help.

My Chrome version is Version 74.0.3729.169 (Official Build) (64-bit)
On a mac, I don’t find an NVIDIA control panel and I don’t find a utility to manage graphics, 3d or otherwise. I’ve created zipped “flags” and “gpu” pages and have attached them. I’m not qualified to call a flag “weird” but perhaps you or a helpful mac geek can see something in these files that solves the issue.

  • John

ps. if relevant, I’m drawing for plasma cutting table, so just 2d shapes and 2d DWG exports…I find the shapes have to be filled to export rather than just being unfilled geometries.

GPU and Flags.zip (387.5 KB)

That is behind a bit. When I opened the chrome “About” page today, … it started an update.
Try this. Seems each time you open this page, Chrome will force an update check.
menu > Help > About Google Chrome

… and the gpu page confirms Chrome IS using your Nvidia GPU.

Thanks for noting that “Chrome IS using my Nvidia GPU”…I’ve updated Chrome to Version 75.0.3770.80 (Official Build) (64-bit) and am going to export a new DWG and see where I’m at. Thanks!

1 Like

35 minutes to export two rectangles and counting…so I think I’m still having trouble. Any additional thoughts?

Thanks! John

I get this within seconds [I’m in the UK]…

09%20pm

so, maybe it will work for you, eventually…

I have tried at all times of day and night without any joy,

john

Now that everyone’s home for the day, I logged into my shop account and tried it on other mac computers, older/newer, more/less powerful, all same version of chrome and OS…they all took seconds instead of hours. So, what’s unique about my machine that’s causing this? Hmm.

Problem discovered. I had some Chrome windows running in the background that affected the Sketchup processes dramatically. All’s running fine now that I’ve terminated those active windows. Alternately, I could open Safari to run Sketchup.

Thanks for your time looking into this, Dan!

John

1 Like

Ah … good information.

Have you ever tried app mode ?

  • (This still loads from the web each time.
    See the next post on how to install to your Apps as a local Progressive Web App.)

On Windows we create a shortcut with the command line:
"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --app=https://app.sketchup.com/app --force-app-mode

Obviously the app path will be different on the Mac, but the parameters should be the same.

… and SketchUp for Web is Progressive Web App ready. They are supported in Chrome from v 73.

Easier installation is coming in Chrome v 76.