SU 2018 - Exporting a 3D DWG always crashes

export

#1

PROBLEM: When trying to export a 3D model as DWG or DXF, SU immediately crashes.

SOLUTIONS TRIED:

• I made a test model with a simple cube and nothing more. Still crashes.

• Disabled all extensions. Still crashes.

• Logged out and logged into a new unused account. Tried exporting. Still crashes.

• Tried exporting a 3D DWG on my wife’s MacBook Pro (also 10.12.6). Still crashes.

• Opened Sketchup using the following Terminal script. Tried exporting 3D DWG. Still craashes,
/Applications/SketchUp\ 2018/SketchUp.app/Contents/MacOS/SketchUp -DisableRubyAPI YES_

I can provide crash reports if that would help.

Here are all my system details:

SU Version 18.0.16976
MacBook Pro (Retina, 15-inch, Late 2013)
OS Version: 10.12.6 (16G1408)
Processor: 2.6 GHz Intel Core i7
Memory: 16 GB 1600 MHz DDR3
Graphics: NVIDIA GeForce GT 750M 2048 MB; Intel Iris Pro 1536 MB


#2

You have two Graphic cards, make sure that SU is using the Nvidia card.
If it is using the Nvidia and is crashing, try the Iris.
Update the card drivers.
No experience with Mac so can’t offer anything specific to that.


#3

+1, and make sure graphics card is set in energy saver in System Preferences.


#4

I cannot select which card SU uses but I can choose to have the OS automatically switch between the two card or be fixed on the high-performance Nvidia. I tried locking it on the Nvidia but SU still crashes.

On macs, we cannot manually update graphics card drivers. That happens as part of OS upgrades only.


#5

Graphics card was set in energy saving, i.e. automatic switching, but is crashing anyway.


#6

Do you have an empty layer in the file?
With empty , I mean the name, not the layer itself


#7

No empty layers. In fact, the only layer in my test file is the default Layer0.


#8

Can you post the simple file that has the problem?
May be, something snug into your template?


#9

It’s not just this simple file — it’s all files. I made the simple file to rule out that it might be an overly complex file or a particular texture or whatever.

In any case, the simple file is at this DropBox link.


#10

try Top View + Parallel Projection >> Zoom Extents >> Export 3D…

works on my mac…

john