WebGL and Slow movements on a Laptop


#1

My laptop is the Lenovo IdeaPad Z510 Notebook, that has Corei7, 16GB memory(upgraded), and on SSD(updraded), running Win10(initially Win8.1), GeForce GT 740M Graphics.
has the latest downloaded Chrome Browser.

Running SketchUp Free is slow on movement, panning and zooming and completely unbearably slow on any movement. then after a few, WebGL error will pop up at the upper left of the screen and the page will turn black. then I would need to load again.

On the other hand, i have a desktop computer, an HP ProDesk 600 G1 DM, Core i5, 16gb memory running Win7 Pro, internal graphics card of Intel ® HD 4600. with the same version of chrome browser installed. - running SketchUp Free on my desktop is smooth as butter no lags, no slowness, no WebGL problems. perfect in running SketchUp Free.

my laptop’s specifications and capabilities far out performs my desktop in paper, but during SketchUp performance, my laptop is a looser… I need to run SketchUp on my laptop most importantly rather than running it on my Desktop.

Anyone know what I need to be doing on this? the only difference I see is that Direct X 12 on my laptop and 11 on my desktop.


#2

This is even with the light-weight default model (empty, scale figure only) or a model with a certain complexity?

Web browsers have a thin implementation layer on top of WebGL that might cause differences (e.g. some web browsers even black-list graphics hardware; or support slow software rendering as fallback). Have you tried a different browser, like e.g. Firefox, just to see if it makes a difference?

You may also try disabling browser extensions (or plugins like flash, if you still have any).

If you have dual graphics hardware (processor-integrated chip and dedicated NVIDIA card) ensure that the browser actually uses the dedicated card for WebGL (although an integrated chip should perform well with the empty default model).

The best graphics hardware does not bring a benefit if the driver support has issues (people are surprised again and again that this affects any newest hardware no matter of price). Even on Windows graphics drivers can sometimes be of significantly poor quality. Your best chance is to update the driver regularly and hope for a soon fix. Get the driver directly from the manufacturer’s website (NVIDIA?) to ensure you are not using a general-purpose generic driver. If you remember the graphics performance once was better, you could also try installing an older driver version to see if it is caused by a newly introduced bug.

WebGL (OpenGL) is a cross-platform, cross-hardware industry standard, whereas DirectX is unlike that and not directly unrelated (but the different DirectX version means your two computers have different drivers, probably affecting also their WebGL compatibility).


#3

Thank you Aerilius, I will try some of the things you have recommended and get back on this thread if ever there are any significant results.

regarding your question, YES, even on light loads, simple rendering.
I have not tried any other browser. - will try to use firefox.
I have tried to disable the Hardware acceleration, to remove getting WebGL errors, but that caused more slowness.

I do have dual graphics, but how would I know which was being used by the browser while rendering?


#4

Unfortunately,

I have used Firefox - System have been crashing
I have updated the NVIDIA Drivers - WebGL Error Still

But to no avail. If I disable Hardware Acceleration I am not getting any WebGL errors although it runs poorly Slow.


#5

Chrome has special built-in diagnostic pages that use a "chrome://" protocol.

To see a list of links to these special pages, use the URL: chrome://about

The special page you are interested in is: chrome://gpu

Please do not post that entire page to this thread. Instead save it to your local drive as an HTML file, and then right-click and send to a zip compressed folder. Drag the zip file into a forum post edit form.


If the browser is using the wrong gpu, then use the Nvidia Control Panel to choose the GPU for Chrome.
(right click desktop it should be on the context menu if installed.)

It’s also a good idea to set your Nvidia GPU as the preferred one for all applications. It has it’s own memory whereas the integrated Intel GPU will use system memory.


Also be aware (search this forum Technical Problems categories) that Windows 10 updates are causing issues with selection slowdown.


SketchUp Free keeps crashing
#6

gpu-Desktop.zip (15.0 KB)

Hi DanRathbun, thank you for this I will try it once ready. I don’t have my laptop with me right now. but here is the chrome://gpu specs of my Desktop, where SketchUp is running smoothly with out any issues.


#7

Consider it a dry run and a learning experience. We’d need the report from the problem machine to help.


#8

gpu-laptop.zip (1.6 KB)

here it is. the problem laptop. where should I be looking?


#9

The laptop file came out blank. The desktop file was fine, and had all the sections of information populated.

Is Chrome installed correctly ?


#10

Thank you DanRathbun, I figured it out, I have activated the NVIDIA card to run performance mode on Chrome, force it to use the NVIDIA card. now Chrome is working with hardware acceleration, and running smoothly without any WebGL error running all good similar to my Desktop.

thank you again.


#11

Excellent ! Thanks for giving the solution to the issue. (You can mark this solved.)


#12

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.