Still broken on linux

Hi, a previous topic on this has been closed with no resolution.

Sketchup web doesn’t work on any recent Linux kernels for machines using Intel graphics hardware. There seems to be an issue with initialising a WebGL context in the browser. Either the scene fails to load or, after loading, as soon as you try to interact with it, the graphics go blank.

Some errors from the JS console:

  • Web GL warning “getParameter invalid parameter name”
  • WebGL “context lost”
  • UserData.ts.migrateUserData was used.

Not sure where to go for support on this?

Does your setup meet these requirements?

SketchUp for Web - System Requirements

Whether you use SketchUp for Web on a computer or Chromebook, your device needs mouse and keyboard input.

Internet Connected Browsers

You can use SketchUp for Web on most internet-connected computers. We recommend using Chrome, Edge or Firefox updated to one of latest two major releases.

To use SketchUp for Web on a Chromebook, your Chromebook needs to meet the minimum specifications. However, the minimum requirements don’t offer the best experience using SketchUp for Web on a Chromebook. Ideally, your Chromebook meets the following recommended specifications.

Yes

I’m using Chrome on Ubuntu. Recent versions of everything.

Hello

Having the same issue.

It was working perfectly with my T14 gen1 / Linux Mint with some intel integrated graphics (UHD ?)

Then I switched to an T14 gen2 with Iris Xe graphics.

Sketch up Web is not longer working, crashing while loading scene.

I’m so frustrated !!

Did you manage to find a way to make it work ?

Thanks

So far I am not aware of a fix, but there is a workaround which is to turn off hardware graphics acceleration in your browser. With Firefox it can be done with an environment variable but I don’t have the name to hand. I believe it can also be done via the settings menu.

Obviously this will slow down scene rendering quite a bit.

I agree it’s very annoying. Hopefully at some point the bug, which seems to be in the intel graphics driver, will get fixed.

I hope so.

Did you manage to disable Hardware acceleration with your browser ?
I tried with firefox (about:config / webgl.disabled=true) : Still crashing

Humm I am a Linux user also an I am having problems with a Video driver also . . But have 16 gig of Ram which runs it all
So what version of Sketchup are you running ? . . Never installed the video driver in windows before at all . . I use the 32bit version of Sketchup as it makes better parts . .with less errors in it . . And I am one of the Linux ( Ubuntu ) Users also ! . . I use it for making parts for a 3D printer an use Virtual Box for windows use 121 megs of video and 4 gig of ram an it screams . . My Graphic card is a Pain in the you know where ! Oh and using 3 of the 8 CPU’s for Virtual Box side ! An this is a Desk top computer got tired of Laptops with no video RAM to speak of ! . . Some DAY I will get a video card which will totally work right ! ! . . LOL . The setting in Virtual Box are what makes or breaks the way that Windows runs ! I also have a shared folder for windows and Linux to share parts to be run in Linux on 3D printer export the file to STL and let sli3er do its thing and make G-CODE for Repetier-Host to run / make the part !

It works for me if I start firefox like this:

LIBGL_ALWAYS_SOFTWARE=1 firefox

Hello Felix

For me it works with Version 113.0.5666.0 (Developer Build) (64-bit) using this installer :

Hope it helps on your side !

This works for me too. Great work finding this solution! I’ve marked it as the solution so others can benefit.

Happy modelling!