Web and Linux

I’m having issues starting Sketchup web on my PopOS laptop. It’s worked for years, most recently in September, but yesterday/today it crashes both Firefox and Chrome. Specifically, I can login and get to my models, but if I click new or try to open an existing, the browser locks hard for Firefox, and Chrome will attempt to create the drawing window, but fails miserably and eventually the window closes. The site did ask me to submit a crash report for Chrome finally today instead of just closing the browser, so that helps. But I was wondering if anyone else was having any issues under Linux recently, and may have a suggestion? Clearing cache doesn’t help, and both browsers are setup to take advantage of the 3D hardware.

I am not a Linux person. What changed on your system prior to the start of the issue?

I was able to bring it up on my other Ubuntu 22.04 box a bit later this morning. Nothing changed on my laptop other than security updates, and possibly upgrading to the latest browsers revisions, but it does seem to be isolated, at least in my case, to my laptop.

If anyone has suggestions on how to recover, I prefer using my laptop, but will survive for now using the NUC.

Does your other computer use the same browser revisions?
Otherwise that could be the culprit.

They are both Ubuntu 22.04 based, most recent. They are the functionally the same installation as both pull the same repo and both most recent (firefox is 106.0.3, Google Chrome 107.0.5304.87). They even have the same processor roughly (11th gen i7 vs 11th gen i5), and same Intel graphics chip (TigerLake-LP GT2 [Iris Xe Graphics] (rev 01)). Different Linux kernel is about the only big difference. PopOS may also do a bit more work on graphics drivers, so maybe it’s there too.

Same behavior here, with Fedora 37 on an Intel Iris Xe card too. Tried with Firefox 106.04 and Chrome 107.5304.110. Linux Kernel 6.0.9. I will try on another machine to see if it is a graphics card related issue.

It runs with no issue on my laptop, the only difference is the HW → NV GTX 1070 Ti.

So it seems to be related to the Intel GPU on recent Linux Kernel, or recent Intel drivers (because it worked perfectly on previous Fedora version on the same machine)

I agree. 5.15 works, 6.0.7 does not, same Intel card. Seems newer Intel support fails the browser somehow.

Maybe you should mark this as solution …